David Server als SMTP Server schickt Mailheader mit

  • Hallo Zusammen,


    wir haben seit heute Mittag ein Problem und können uns nicht ganz erklären wo das alles her kommt.


    Wenn wir aus David Tobit eine E-Mail an eine externe Adresse schicken funktioniert alles wunderbar.


    Wenn wir aber eine Mail über ein anderes Programm extern verschicken (Relay) und als SMTP Server ist unser Mailserver eingetragen wird der Mailheader der E-Mail voran gestellt und Anhänge (z.B .PDF) wird unlesbar. Der Anhang wird dann als Text in der E-Mail dargestellt.


    Wenn wir eine Mail über das gleiche Programm (oder Scanner) eine intern verschicken funktioniert alles.


    Hier ein Beispiel:


    X-DvISE-ForwardJob: Try count: 1, FirstTry: Thu, 19 Jul 2018 14:48:55 +0200

    Received: from PC87 [192.168.xxx.xx] by 192.168.xxx.xx with David.fx (xxxx.4743464A48474xxxxxxx);

    19 Jul 2018 12:48:55 UT

    From: edv@xxx.de

    To: xxx@outlook.de

    Subject: TESTMAIL

    Sender: edv@xxx.de

    Mime-Version: 1.0

    Content-Type: text/plain; charset="iso-8859-1"

    Date: Thu, 19 Jul 2018 14:48:55 +0200


    Testmail zum Testen der Emaileinstellungen

    Gesendet von xxx.



    Normal sollte nur das in der E-Mail stehen:


    Testmail zum Testen der Emaileinstellungen
    Gesendet von xxx

  • ch habe die Erfahrung gemacht, dass wenn der PostMan als Forwarder arbeitet, im Ausgang des System Users zwar die Mail so angezeigt wird, beim Empfänger aber korrekt ankommt.

    Ja das kann ich bestätigen.

    Wir haben eine WaWi im Einsatz und nutzen auch den Postman um zu überprüfen ob auch alles verschikt wird


    Dort wird es ebenfalls so angezeigt:


  • Sorry, dass ich mich hier um 21/2 Jahre verspätet einklinke, aber wir stehen auch vor diesem Problem. Aber nachdem nun das Thema hier als erledigt abgehakt ist, ich in den Beiträgen jedoch keine Lösung erkennen kann, wollte ich darum bitten, mir diese nochmals mitzuteilen.


    Vielen Dank!

  • Sorry, dass ich mich hier um 21/2 Jahre verspätet einklinke, aber wir stehen auch vor diesem Problem. Aber nachdem nun das Thema hier als erledigt abgehakt ist, ich in den Beiträgen jedoch keine Lösung erkennen kann, wollte ich darum bitten, mir diese nochmals mitzuteilen.


    Vielen Dank!

    Das verwundert nicht, das Du in den Beiträgen keinen Lösungsweg findest, denn damals hat man augenscheinlich herausgefunden das es sich nur um ein kosmetisches und kein reales Problem handelte...

  • bisher hat mich das nicht gestört, weil es halt bei dem Empfängern lesbar ankommt.

    Aber ich guck mir das gerne mal im Detail an.

    Die Mails jedenfalls sind bei uns intern recht leicht lesbar zu machen, es müssen nur 2 Zeilen aus dem Header gelöscht werden, schon ist die Nachricht im David Editor ganz normal lesbar.

    Der David Server hängt beim externen weiterleiten der per SMTP erhaltenen Nachrichten einen eigenen Content Type Header vorne an, welcher allerdings aussagt das es sich um eine plain Text Nachricht handeln würde.
    Dummer Weise wertet der David Mail Client / Editor nur den ersten dieser Content Type Header aus um zu entscheiden wie er den Rest der Nachricht behandeln soll.
    Löscht man diesen ersten Content Type Header kann die Nachricht sowohl vom David Client, als auch von allen anderen Mail Readern normal behandelt werden.
    Die meisten anderen Mail Reader werten alle im den Header Zeilen enthaltenen Content Type Header aus und der letzte gewinnt, daher stellen sie das ganze dann auch korrekt dar ;)

    Es gibt da noch einen weiteren Fehler in der von David beim smtp forwarding erzeugten Mail, welcher für die Anzeige durch den David Client und wohl auch die meisten anderen Clients nicht von Bedeutung ist, allerdings dennoch klar gegen geltende Standards verstößt und von daher bei anderen Mail Programmen eventuell zu fehlern führen kann.
    Und zwar findet sich eine Leerzeile zwischen den Headerzeilen welche bis einschließlich der Annahme per smtp durch den David Server entstanden sind.

    Ich denke mal das wird man bei Tobit melden müssen, damit sie es korrigieren und genau das wird bislang noch niemand getan haben.

  • Ich hab es nicht gemeldet weil ich nicht einmal weiß was ich genau melden soll :) kann es aber gerne tun wenn ich es gesagt bekomme :P

    Einfach mit eigenen Worten beschreiben was stört und dann die Rückfragen beantworten ;)

    Nee, im Ernst, ich melde ja im Normalfall auch nur was uns persönlich stört.
    Was so wie dieses Problem völlig unterm Radar schwimmt melde ich auch nur wenn ich es hier mitbekomme und merke das der Leidensdruck bei anderen groß ist und es helfen könnte wenn es mehr Leute melden.

  • In diesem Thread berichten mehrere User, dass Tobit das Verhalten von David an der Stelle nicht als Bug ansieht. Aber vielleicht bewirken weitere Anfragen ja, dass der Hersteller doch noch eine Lösung bastelt.


    Mich persönlich stört es nicht übermäßig; am wichtigsten ist für uns, dass im Ausgang ersichtlich ist, ob die Mails aus der Warenwirtschaft ordnungsgemäß versandt wurden. Wenn man dann das angehängte PDF auch noch öffnen könnte, statt nur die base64-Codierung anzuschauen, wäre das natürlich praktisch. ;)

  • Mich persönlich stört es nicht übermäßig; am wichtigsten ist für uns, dass im Ausgang ersichtlich ist, ob die Mails aus der Warenwirtschaft ordnungsgemäß versandt wurden. Wenn man dann das angehängte PDF auch noch öffnen könnte, statt nur die base64-Codierung anzuschauen, wäre das natürlich praktisch. ;)

    Wenn Du das nur im Einzelfall mal prüfen willst ist das simpel, einfach die Nachricht mit der Maus aus dem entsprechenden Postausgangsarchiv z.B. auf den Desktop ziehen und dort dann mit einem Texteditor öffnen. vor der ersten Leerzeile nach "Content Type" suchen, diese Zeile + die darauf folgende löschen, das ganze speichern und fertig. anschließend lässt sich die Nachricht per Doppelklick mit dem David Client Viewer öffnen und die Anhänge lassen sich zu Prüfzwecken anschauen.

    Eigentlich muss Tobit an dem Verhalten seines Systems eigentlich nur eine Kleinigkeit ändern.

    Entweder lassen sie bei rein nach extern weitergeleiteten Mails diese zwei HeaderZeilen weg, welche eh nicht Standardkonform sind.

    Oder sie werten beim betrachten solcher Mails auch die Original Headerzeilen aus und verhalten sich so wie fast alle anderen Mail User Agents, wo immer der letzte gefundene "Content Type" Header gewinnt.

    Aus logischen Gründen wäre ich natürlich für die erste Variante ;)

  • Einfach mit eigenen Worten beschreiben was stört und dann die Rückfragen beantworten ;)

    Nee, im Ernst, ich melde ja im Normalfall auch nur was uns persönlich stört.
    Was so wie dieses Problem völlig unterm Radar schwimmt melde ich auch nur wenn ich es hier mitbekomme und merke das der Leidensdruck bei anderen groß ist und es helfen könnte wenn es mehr Leute melden.

    Ja ich schau mal o ich das morgen schaffe :)

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!