Sporadisch Fehlfunktion Fax mit Primux USB 2

  • Hallo,


    sporadisch hängt sich bei uns die Primux USB 2 Box weg (bisher noch nicht länger als 14 Tage bis zum nächsten Hänger). Vom Server aus gesehen sieht alles gut aus, TLDs laufen, Gerätemanager ok, keine Einträge im Ereignisprotokoll. Prüft man mit dem Tool von Gerdes ("Verbindungstest"), kommt die Fehlermeldung "Es war kein Zugang zum ISDN-Netz möglich. Dies kann mehrere Gründe haben: Die Kabelverbindung ist beschädigt / Ihr ISDN-Anschluss ist derzeit überlastet".


    Der David-Server wurde kürzlich von Blech (W2K8 R2) auf Blech (W2K16) migriert. Leider können wir die vorher eingesetzte Dialogic DIVA BRI-2 nicht mehr einsetzen. PCIe wäre zwar im neuen Server noch vorhanden, aber der Hersteller erteilt keine Freigabe für den alten PCIe-Standard der DIVA.


    Daher sind wir den Weg zur kostengünstigen Primux USB 2 gegangen, nicht zuletzt aufgrund der Infos hier im Forum.


    Die Primux-Box hängt an einem internen S0 einer Panasonic TK-Anlage (wie die DIVA vorher auch). Ein TLD läuft RX/TX einer nur RX.


    Im Monitor des jeweiligen TLD tauchen öfter mal "DISCONNECT_IND (0x3304) Another application got that call" auf. Das scheint kein Problem zu sein. Sieht fast so aus, als ob sich die TLDs da gegenseitig Konkurrenz machen. Aber wenn die Box sich weghängt, dann findet sich auch typisch "DISCONNECT_IND (0x3303) Protocol error layer 3".


    Hat hier wer ähnliche Erfahrungen gemacht oder vielleicht sogar eine Lösung für dieses Problem gefunden? Kann es wirklich sein, dass die Box durch "Überlastung" des S0-Bus dermaßen irritiert wird, dass sie sich weghängt?


    Ein Firmware-Update (Stand April 2019) und die aktuellsten Treiber (3.9.128-gd48eedb) für die Primux-Box haben wir bereits auf Empfehlung des Support von Gerdes durchgeführt.


    Gruß

    fx.trix

  • Moin,

    ich kann Deine Probleme bestätigen und habe diese Problematik sowohl bei mir, als auch bei einigen Kunden. Ich habe allerdings auch Kunden, bei denen exakt die gleiche Konfiguration ohne jegliche Probleme läuft.


    Ich hatte bereits Traces an Tobit und an Gerdes geschickt und beide haben mir versichert, dass es an der jeweils anderen Komponente liegt.


    Aktuell behelfe ich mir damit, alle TLD.EXE Dienste zeitgesteuert per taskkill abzuschießen und kontrolliert neu zu starten.


    Wenn der TLD hängt sehe ich im Status "...disconnecting" und der Dienst lässt sich nicht stoppen bzw. neu starten, lediglich der taskkill hilft.


    Eine wirkliche Lösung kann ich Dir leider nicht anbieten.


    Jörg.

  • Hallo,

    ich hatte bei einem Kunden das gleiche Problem - allerdings mit einer anderen Software: SPEXBOX.


    Mittlerweile steht auf der Herstellerseite der Software, dass USB-Adapter nicht empfohlen werden.

    Daher würde ich die Ursache eher bei GERDES als bei Tobit sehen.

  • Nachtrag: mittlerweile scheint das Problem gelöst. Die Lösung bestand in unserem Fall in der Anpassung des ISDN-Protokolls auf dem S0-Port der TK-Anlage. Ich war leider nicht bei der Modifikation dabei und kann hier daher nicht die spezifischen Änderungen dokumentieren, aber wer so einen Primux USB 2 an einem internen S0 einer TK-Anlage angeschlossen hat und diese Hänger bekommt, kann ggf. dann in der TK-Anlage ansetzen.

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!