POP3 Abruf geht aktuell nicht

  • Nach der kompletten Neuinstallation eines Servers (nun 2019 Standard) incl. David.fx (Version von 03.2016)

    hat der Grabbing Server alle auf dem Providerserver verbliebenen Mails brav erneut abgeholt (37934 Mails :-) )


    Leider holt er aktuelle (neu eingegangene Mails) nicht ab. Im Webmailer des Providers sind diese zu sehen.

    Das Postfach ist im Grabbing Server O.K. (Testbutton geht ...)


    Hier mal ein Auszug aus dem Monitor:


    (00001136) Got complete TCP Message (Size=24)

    (1) +OK Password required.

    (00001136) write (15)

    (00001136) read (16/0)

    (00001136) Got complete TCP Message (Size=16)

    (1) +OK logged in.

    (1) STAT

    (00001136) write (6)

    (00001136) read (22/0)

    (00001136) Got complete TCP Message (Size=22)

    (1) +OK 22231 5511022101

    (1) Open Messagelist file (\\server-xxx\david\apps\dvgrab\code\I0374838.lst)

    (1) LIST

    (00001136) write (6)

    (1) +OK POP3 clients that break here, they violate STD53.

    (1) UIDL 1

    (00001136) write (8)

    (00001136) read (39/0)

    (00001136) Got complete TCP Message (Size=39)

    (1) +OK 1 1456590929.M856957P28970.baldur

    (1) UIDL

    (00001136) write (6)

    (1) +OK

    (1) RETR 22229

    (00001136) write (12)

    (1) Read Message failed

    (1) QUIT

    (00001136) write (6)

    Poll Mailboxes (1)

    Resume Thread (1) for xxxxxxxxx.de (mail.x-dot.de)

    Pop3 1 Thread active

    (00001136) New Socket

    RESOLVE A mail.x-dot.de

    (00001136) UDP SendTo (31)

    QUERY/QUERY/RD/No Error



    (1) Read Message failed und Resume Thread (1) sind wohl das Problem, weiss aber nicht warum.

    Polling Intervall 5 Minuten.


    Folgende Einträge in der dvgrab.ini habe ich (ohne Erfolg) ergänzt


    WatchdogDelay = 250

    ; Default is 55 seconds

    ; Specifies the maximum time to wait for incoming data blocks


    MAXPOP3THREADS = 1


    Auch Einträge aus dem Ordner David\import\system habe ich (auch ohne Erfolg) gelöscht



    Virenscanner ist aktuell nur Defender. Im Eingangsprotokoll ist nix :-/


    Der Provider ist aktuell schlecht / gar nicht zu erreichen um evtl. zu sehen ob er Abruf

    sämtlicher Mails zu einem Problem geführt hat?


    Ideen gegenüber die Abhilfe schaffen könnten bin ich sehr aufgeschlossen :-)

    zapp

  • Als Action im Status Monitor des Grabbing Servers steht die ganze Zeit: empfangen

    Verbindungen: zwischen 4 und 72 habe ich gesehen

    Aktive Verbindungen: 1


    Was steht in dieser Datei (I0374838.lst), sind es die ID der bereits abgerufenen Mails?


    (1) Open Messagelist file (\\server-xxx\david\apps\dvgrab\code\I0374838.lst)

  • ist noch ein Pop Proxy dazwischen?


    Ähnlich sahbdas bei mir aus, wenn eine "defekte" mail im Postfach liegt, welche der pop Proxy nicht abrufen konnte.

    Tobit FX12 auf W2016 an VMWare ESXI6.5 Essentials,
    ActiveSync über Sophos SG210 /Reverse Proxy(WAF) - SMTP Proxy TLS

  • Hallo,


    "leider"kein POP Proxy.


    Defekte Mail kann ich auch ausschliessen, es sind nur reine Text-Testmails von mir aktuell im Postfach die noch nicht abgerufen wurden :-/

  • Was steht in dieser Datei (I0374838.lst), sind es die ID der bereits abgerufenen Mails?

    Genau.


    Ich kann mir eigentlich nicht vorstellen, dass die Größe der .lst-Datei damit was zu tun hat.
    Irgendwas scheint mit den anderen Mails zu sein.


    Wir rufen z.B. bei verschiedenen Providern die POP3-Postfächer ab (alte E-Mail Adressen einzelner Benutzer).
    Da tritt das Verhalten auch vereinzelt auf, aber unabhängig vom Provider. Mal ist es GMX, mal T-Online...

  • Youbird


    genau das war es. Bin ich dann leider erst spät drauf gekommen das das wohl ein timeout war. Blöderweiser webmailer unkomfortabel über HORDE zu bedienen. Blöd zu konfigurieren und saulangsam. Ordner "Papierkorb" erstellt, 22257 Mails markiert (nur das markieren hat ca. 1h gedauert!), dann gelöscht bzw. in Papierkorb verschoben bis auf die letzten 200 aktuellen Mails - seit dem läufts .... puuuhhh

  • Umstellen auf SMTP Zustellung ohne POP ist nicht gewünscht?


    Sofern es sich um Mail Boxen handelt wo man den MX umstellen kann, was bei t-online.de oder GMX und Web.de Adressen nicht geht.

    Tobit FX12 auf W2016 an VMWare ESXI6.5 Essentials,
    ActiveSync über Sophos SG210 /Reverse Proxy(WAF) - SMTP Proxy TLS

    Edited once, last by BlackShadow ().

  • Hallo,

    ich habe hier das problem das tatsächlich bei einigen postfächern eine defekte mail im webmailer vorhanden ist und der david grapping server diesen nicht abruft. bzw auch alle mails die danach gekommen sind werden nicht abgerufen.

    dadurch dass das einige postfächer betrifft könnte ich zwar in jedes mich einloggen und die mail löschen, aber kann man das irgendwie auch anders lösen?

  • hallo, wie mal geschrieben.

    Hatte es beim Kunden auch ab und an.

    Die Mail war so schon ok, nur irgend was passte dem POP Grabbibg nicht, bei einem hatte die Sophos Pop Proxy Probleme mit den Mails.


    Wurde umgestellt von POP auf SMTP Zustellung, seither ruhe.

    Tobit FX12 auf W2016 an VMWare ESXI6.5 Essentials,
    ActiveSync über Sophos SG210 /Reverse Proxy(WAF) - SMTP Proxy TLS

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!