Plötzliche Fehlermeldung bei Active Sync mit Android Gmail App und David

  • Hallo seit diesem Wochenende haben einige Android Gmail Apps Probleme mit der David Webbox zu synchronisieren.

    Folgende Fehlermeldung erscheint:

    "Die Sicherheitseinstellungen von Gmail sind momentan strenger als die von Ihrem IT Administrator festgelegten Einstellungen"


    Hat jemand eine Idee?


    Gruß

    Andreas

  • Dieses Problem ist an mich auch gerade herangetragen worden. Ich habe die Webbox des Kunden nun so weit optimiert, dass auf ssllabs.com ein "A"-Rating angezeigt wird, bisher war z. B. noch TLS 1.1 aktiviert. Es kam allerdings bislang keine Rückmeldung, ob das Problem dadurch beseitigt wurde.


    Mit Office365 scheint es ebenfalls Probleme zu geben. Lt. des verlinkten Threads hilft es wohl, die Updates der GMail-App zu deinstallieren, zumindest als Workaround.

  • Moin, habe auch das oben beschriebene Problem mit der Gmail-App (dieselbe Fehlermeldung inzwischen auf drei Android-Geräten). Synchronisation zwischen der App und David funktioniert nur so lange das neueste Update für Gmail sich nicht installiert. Nach dem zurücksetzen auf die Werksversion (durch Deaktivierung der App) ist die Synchronisation mit dem David-Server eine Zeit lang möglich, bis wieder das Update erfolgt. Ich weiß nicht, wie man das automatische Updaten für eine bestimmte App verhindern kann. Wahrscheinlich geht es nur so, dass man das automatische Update für alle Apps abschaltet.


    nordtech Kannst du bitte mal etwas näher deinen Workaround erläutern. Also was du wie und wo konkret verändert hast?

  • Hier im Forum kam mal der Tipp, im David-Admin unter TLS-Verschlüsselung auf "Benutzerdefiniert" zu stellen und dann manuell bei den verwendeten Ciphers folgendes einzutragen:


    ECDHE-ECDSA-AES256-GCM-SHA384:ECDHE-RSA-AES256-GCM-SHA384:ECDHE-ECDSA-CHACHA20-POLY1305:ECDHE-RSA-CHACHA20-POLY1305:ECDHE-ECDSA-AES256-SHA384


    Im gleichen Dialog hab' ich TLS 1.1 abgewählt. Ferner in den Eigenschaften der Webbox die Übermittlung der Zertifikatskette eingeschaltet, anschließend ist ein Neustart des Webbox-Dienstes nötig.


    Mit dieser Konfiguration bekomme ich wie erwähnt eine "A"-Einstufung, von daher ist dann Webbox-Seitig vermutlich alles getan, was getan werden kann.


    Wie gesagt, Rückmeldung vom Kunden gab's bisher keine, daher ohne Gewähr, ob das im konkreten Fall wirklich hilft. Ich wollte nur im Vorfeld ausschließen, dass die Webbox noch mit veralteten Ciphern kommuniziert.

  • Danke für die Vorschläge. Bei uns haben sie allerdings nicht zum Erfolg geführt. Das liegt vielleicht daran, dass die Postfächer beim Hoster liegen und die Firewall diese abholt und an David weiterreicht. ggf. ist deswegen eine A-Einstufung erfolglos.


    Geholfen habe ich mir mit dem Zurücksetzen der GmailApp. Nach dem Anlagen des Kontos funktionierte alles sofort wieder (in beide Richtungen). Was auffällig ist, die Erstellungsdialoge unterscheiden sich von einander. Mit neuer App wird nicht nach (pop, imap, Exchange), sondern nach (pop, imap, Webdav) gefragt. Soweit ich das in Erinnerung habe benutzt EAS Wedav für die Verbindung zu den Userordnern.

  • Hatten das auch und habe bei der WebBox folgendes eingestellt:

    Konfiguration/ActiveSync/Provisioning/Enforce Provisioning


    Danach ging es. Allerdings kann ich jetzt nicht mehr sagen, ob es mit einem bestehenden Konto auch geht,

    da ich das Konto entfernt und neu angelegt habe.


    Nachtrag:

    Es scheint auch mit vorhandenem Konto zu funktionieren, wenn man die Konfiguration in der WebBox

    vornimmt und dann bei der Fehlermeldung "Die Sicherheitseinstellungen von Gmail sind momentan strenger als die von Ihrem IT Administrator festgelegten Einstellungen" auf "Bestätigen" drückt.

  • Das hat aber jetzt nichts damit zu tun, oder?

  • Hallo zusammen,


    danke Dir Youbird. Die Anpassungen kann ich so bestätigen, habe ich gerade bei unserem Kunden getestet. Die Einstellung hat es gebracht.


    Vielen Dank und weiterhin viel Erfolg!

  • Problem habe ich nun allerdings bei Outlook...


    Outlook an David anbinden?


    Habe dann via Google dieses Thema gefunden. Bei meinem Office 365 Outlook synchronisiert er dank der erzwungenen Provisierung leider nicht mehr....

    teufelskreis....


    Weiß jemand ob es eine Abhilfe gibt die beides unterstützt?


    File: outlook\pstprx\storeas\utils\airsyncstatuscodes.h

    Line: 240

    HTTP/1.1 200 OK

    FolderStatus: 142

    To re-try press F9...

    Fehlercode: 0x80004005


    Habe soeben auch intercom geschrieben.

  • Mit dieser Konfiguration bekomme ich wie erwähnt eine "A"-Einstufung, von daher ist dann Webbox-Seitig vermutlich alles getan, was getan werden kann.

    Servus, wie hast du das denn gemacht? ;-)


    This server does not support Forward Secrecy with the reference browsers. Grade capped to B. MORE INFO »

    This server's certificate chain is incomplete. Grade capped to B.

    This server supports TLS 1.1. Grade will be capped to B from January 2020. MORE INFO »


    Gruß Gen

    ****************
    Wohl bald ehemaliger "Tobit Partner" :cursing: 2001 - bald wären es 20 Jahre...<X So geht man nicht mit seinen Partnern um !! Stichwort _Provisionen_.
    ****************

  • So als Info für euch, David hat uns via INtercom geholfen und eine neue webbox.exe geschickt. DAmit klappt dies nun mit erzwungen bei Gmail und bei Outlook wieder.


    Quote


    Laden Sie folgende Version der Webbox herunter:

    xxxx
    Beenden Sie die Webbox, benennen Sie die webbox.exe im Verzeichnis david\apps\webbox\code um und kopieren die neue Version dort hin. Starten Sie nun die Webbox. Prüfen Sie die Funktion mit Outlook und geben Sie uns kurzfristig eine Rückmeldung. Viele Grüße, Stefan von Tobit Software.

    Ich habe den Link einmal entfernt, da ich nicht weiß ob die das wollen, das man so eine "beta" verbreitet.


    Ich habe denen gesagt es klappt, und ich glaube es wird ein Hotfix davon gebaut, bzw kann ich mir vorstellen.


    VIele Grüße

  • Servus, wie hast du das denn gemacht?

    Wenn ich die oben angegeben Cipher hinterlege, klappt's bei mir. Wichtig ist natürlich ein gültiges Zertifikat (bei mir via eingebautem Let's-Encrypt-Automatismus) und Haken raus bei TLS 1.1 sowie Haken rein bei "Zertifikatskette übermitteln".


    Welche dieser Schritte die Forward Secrecy betrifft, kann ich allerdings leider nicht sagen, habe mich auch darüber gewundert, dass diese Meldung im Zuge dessen verschwindet. Vielleicht kann das ein Krypto-Auskenner beantworten. ;-)

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!