Strongbox Rücksicherung 16 Stunden ?

  • Hallo liebes Forum!


    Steht ja eigentlich schon im Topic. Habe gestern mein Tobit Basic neu installiert (bzw mein kompletten Rechner), und sichere "mal eben" meine Emails zurück. Das sind paar tausend Mails, das Strongbox-Image ist ca. 1 GB groß.


    Aber ist es normal das diese Rücksicherung fast einen geschlagenen Tag dauert ?


    Der sichert mit 1,5MB/min zurück, ist bei 50% (8 Stunden, 55 Min). Und es ist auch nicht das erste mal das ich das mache. 20-30 Minuten kenne ich so als Zeit, aber 16 Stunden ?


    Jemand eine Idee ?


    Win 10 Pro, SSD, 8 Kerner, Win 10 komplett frisch installiert, Tobit quasi das erste Programm.

  • Das ist kein guter Wert, aber die erreichbare Geschwindigkeit hängt nicht alleine von der SSD ab.

    - Wo liegt Dein Strongbox-Image: Lokal, USB-Platte, Netzwerk (NAS)? Am schnellsten geht es mit einem lok. Image, ansonsten kann unter bestimmten Voraussetzungen sogar das Netzwerk schneller als die USB-Platte sein.

    - Ist das DAVID-Verzeichnis als Ausnahme im Virenscanner des Servers definiert? Am besten schaltest Du den Virenscanner für das Einspielen der Strongbox ganz ab und danach nimmst Du in jedem Fall die ARCHIVE.DIR und ARCHIVE.DAT-Dateien in die Ausnahmenliste des Virenscanners mit auf.


    Beim Rücksichern legst Du eine Unmenge von kleinen Einzeldateien auf dem Server ab. Da sinkt auch die Performance einer SSD dramatisch. Wenn dann noch der Virenscanner jede einzelne Datei untersucht oder die Verhaltenskontrolle/Ransomware-Überwachung mit reinpfuscht, dann kann es absurd lange dauern, bis eine größere Strongbox zurück gesichert ist.

  • Das Backup liegt auf einer NVMe SSD auf C:\, er kopiert quasi auf sich selber. Sollte eigentlich fix gehen. Antivirenprogramm ist nicht mal installiert, weil Tobit immer das erste ist, was ich mache.


    Sehr seltsam das ganze.



    Er ist jetzt bei 80% mit 16 Stunden.... bei 1,3MB/min.

  • Das Backup liegt auf einer NVMe SSD auf C:\, er kopiert quasi auf sich selber. Sollte eigentlich fix gehen. Antivirenprogramm ist nicht mal installiert, weil Tobit immer das erste ist, was ich mache.

    Da auch die Windows Server Versionen mittlerweile alle standardmäßig einen Windows Defender mitbringen der auch standardmäßig aktiv ist würde ich an Deiner Stelle da noch mal genauer nachgeguckt haben ;)


    An der NVMe SSD wird es bei einem nur 1GB winzigen Strongbox Image jedenfalls ganz sicher nicht liegen, es sei denn sie wäre wirklich schon sehr voll.

    Solche Zeiten kenne ich eher von Strongbox Images mit mehr als 1TB...

  • Werde nochmal rumprobieren, es sind lt. Strongbox Image in meinem Eingang ca. 30000 (dreissigtausend) Mails.


    Kommt mir gerade überraschenderweise auch sehr viel vor, Mails gehen zurück bis 2015.


    Aber selbst diese Fülle von Dateien dürfte ja von SSD nicht sooo lahm sein.


    Einen richtigen Server gibt es nicht, mein Win 10 pro ist quasi auch der Server,

  • Ein Windows 10 bringt erst recht grundsätzlich den Windows Defender mit.
    Wenn man darin während der StrongBox Wiederherstellung den Servicelayer nicht als Ausnahme definiert kann das in solchen Fällen für viel Wartezeit sorgen.

  • Alles deinstalliert und nochmal von vorne. Ergebnis ist das gleiche. Es ist noch nichts installiert, Ich habe in Defender einige Ordner ausgeschlossen, und SL.exe ebenso.


    Er sichert wieder mit 1Mb/Min zurück. Ich verstehe es nicht und muss mich wohl damit abfinden.


    Ach, manchmal sehne ich mich nach einer einfachen .PST Datei zurück...…..

  • wie voll ist Dein SSD, wie viel Overprovisioning ist konfiguriert, wie alt ist es, bzw. wie viel TBw hat es schon auf dem Buckel und wann ist es zuletzt geleert worden und hat dabei ein ein Trim gesehen?

    NVMe SSDs sind toll wenn sie noch nicht zu stark saturiert sind, aber wenn man sie nicht optimal einsetzt werden sie schnell sehr sehr viel langsamer. Richtig einsetzen heißt in Anhängigkeit davon wie viele kleine oder große Dateien wie häufig oder selten geschrieben, geändert oder gelöscht werden einen mehr oder weniger großen Bereich fürs Overprovisioning frei zu lassen, damit der Controller des SSDs nicht zu häufig Daten umsortieren muss wenn er neue Daten schreiben soll.

    Leider sind gerade viele günstige NVMe SSDs nur deswegen mit guten Schreibwerten ausgewiesen weil sie einen SLC Cache an Board haben, der aber hat eine endliche Größe und wenn der voll läuft wird es zäh. Wenn der Controller dann noch nicht mal genug freien ungenutzten Platz zur Verfügung hat den er für seine Sortieraufgaben nutzen darf wird das nicht besser.

    Nimmt man dann noch dazu das Dein Rechner gerade tonnenweise kleinste Dateien auf die Platte schreiben soll und einige davon sich auch noch ständig ändern (Archive dat und .dir) macht es die Aufgabe nicht unbedingt besser.

    Wenn dann das NTFS noch mit den falschen Werten erstellt wurde - was in diesem Fall Standard meint - und nicht berücksichtigt das auf ihm unglaublich viele winzige Dateien gelagert werden sollen kommt der Nächste Nagel in den Sarg der Performance.

    Wenn ich noch eine Weile weiter drüber nachdenke kommen mir sicher noch mehr Parameter in den Sinn welche man in der Konstellation als Engpass in Betracht ziehen müsste...

  • 960 Pro Evo, angebunden über PCIe. Also die Geschwidigkeit spielt da keine Rolle, die Platte ist auch frisch formatiert von Windows.


    Das Strongbox-Image liegt mittlerweile auch auf einer anderen SSD von der ich zurück sichere. Tobit lief ja auch fehlerfrei bis dahin. Hatte extra vorher noch ein Full Image gemacht.


    Finde das sehr suspekt, weil ich das vorher so in der Form auch noch nie hatte.


    Und es ist alles wirklich frisch installiert, also auch neues SQL, kein Antivirenprogramm drauf nichts.


    Ich habe ja ein Parititions-Image von den alten Daten inkl. Archive-Verzeichnis. Ist es irgendwie möglich die Daten aus dem Userverzeichnis auf die neue Tobit Installation zu veschieben ?


    Hatte das gestern mal probiert, aber Tobit hat natürlich nichts angezeigt. Nach Einsatz von Arcutil war alles da, aber wie man von Arcutil halt gewohnt ist, waren alle Betreffs weg, und alle Emails hießen "ArcUtil Recovery" oder so ähnlich. :D

  • 960 Pro Evo

    Was denn nun? Pro oder Evo?


    die Platte ist auch frisch formatiert von Windows.

    Das ist nicht relevant wenn kein Trim aktiviert ist.

    Sollte es eine EVO und keine Pro sein solltest Du zudem mit dem Samsung Magician 20% Overprovisioning einrichten, wegen Tobit und der vielen kleinen Dateien eher sogar 25%, bei einer Pro würden es auch 10 bzw. wegen Tobit 15% tun.


    Ich habe ja ein Parititions-Image von den alten Daten inkl. Archive-Verzeichnis. Ist es irgendwie möglich die Daten aus dem Userverzeichnis auf die neue Tobit Installation zu veschieben ?

    Du hättest schlicht die ganze Tobit Installation wieder an ihren Platz kopieren und dann Tobis genau dort hin drüber installieren können, dann wäre alles sofort wieder da.
    Allerdings setzt das voraus das der Rechnername identisch bleibt.

  • Wie auch immer was eingestellt ist, sollte doch die Rücksicherung nicht solange dauern. Habe gerade mal meinen Benutzerordner von A nach B kopiert. 80000 Dateien, hat knapp 7 Minuten gedauert von SSD zu SSD.


    Ich weiß auch nicht ob ich der einzige mit diesem Problem bin, es liegt auf jeden Fall mal nicht an der Hardware. Und auch wenn .stbox sowas wie ein Image/Containerformat(?) ist, verstehe ich diese langwierige Wiederherstelllung nicht.


    Deinen letzten Tipp werde ich beim nächsten mal aber sowas von beherzigen, dann wäre das ganze Ding in 10 Minuten erledigt. Da es nur mein privater Rechner ist, kann er natürlich immer den gleichen Namen haben. ;P

  • Das kann man halt nicht vergleichen: Beim reinen Kopieren (so wie im Tipp von Riawie) werden wirklich nur die Dateien von A nach B bewegt. Das entspricht Deinem 80000-Dateien Test und geht schnell.


    Wenn Du statt dessen aus der Strongbox wiederherstellst, dann holt der Service-Layer eine Email aus der gepackten Datei, entpackt die Email im Speicher, schreibt 2+X - Dateien (das X sind die Anhänge) in das Zielverzeichnis, dann erweitert er die ARCHIVE.DAT-Datei um einen 430 Byte großen Eintrag (430 Byte an eine bestehende Datei anfügen, das mögen alle SSD's :) ohne Overprovisioning). Wenn man beim neu installierten DAVID nichts im Eingang hat und dann mit der Strongbox 30000 Dateien hinzufügt, dann schreibt die SSD an dieser Stelle 30000 mal in die ARCHIVE.DAT-Datei und hängt jedesmal 430 Byte dran. Beim reinen Kopieren dagegen wird nur einmal eine ca. 12,9 MByte große Datei geschrieben.


    Dann läuft noch die Volltextsuche über Deine neu hinzugefügte Einzelemail drüber und erst danach kommt die nächste Email aus dem Image dran. Das Ganze läuft dann auf Deiner 8-Kern Maschine größtenteils auch nur auf einem Kern (weil das alles der Service-Layer als Dienst alleine macht) und schon gar nicht mit Volllast, weil der Dienst gar nicht 100 % Leistung vom System bekommt.


    Die 16h sind zwar krass, aber erklärbar.

  • Also imo ist das viel zu lahm. Wie hast du die Daten zurückgesichert? Ich hatte letztens ähnliche Probleme bei einem Kunden. Das Rücksichern über den David Administrator war auch so langsam. Wenn ich hingegen das Strongbox Image im Client gemounted habe und von dort aus die Inhalte der Ordner per Copy & Paste kopiert habe war es derbe schnell.

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!