SMTP Versendet bei "Verbindungsfehler" nur ein einziges mal?

  • Hallo David-Community,


    ich habe ein kleines Problem mit meinem David-Server.


    Erzeugt eine E-Mail beim Senden einen Verbindungsfehler, dann ignoriert der SMTP die weiteren Versuche und schmeißt die E-Mail direkt zurück in den Eingang. Unser David-Reseller ist dieses Problem noch nie untergekommen und er kann mir leider nicht helfen.


    Ist dem Forum dieses Problem bekannt?


    Wir verwenden Version: 12.00a - 3112, Einstellungen sind in den Screenshots zu sehen, weitere Daten nenne ich gerne auf Anfrage.


    Viele Grüße,

    Eisenhuth


    Update:


    Also ein Teil des Problems ist nun weg. Nachdem der Dienstleister des Empfängers mal sein System kontrolliert hat, kommen nun auch nicht mehr diese Meldungen. E-Mails gehen wie gewollt raus.


    Generell hatte ich dieses Problem allerdings nicht nur bei einem Anbieter. Da ich allerdings vor kurzem zu viel an unserer Infrastruktur geändert habe, möchte ich hier nicht über Dinge in der Vergangenheit reden. Ich würde das ganze gerne nochmal im Auge behalten und mich dann nochmal mit aktuellen Logfiles zurück melden.

  • @@wiederholung 250@@ steht vermutlich nicht in den Mails mit drin, daher wird es auf einen permanenten Fehler hinauslaufen den der empfangende SMTP dem Postman präsentiert. Daher mal im Monitor schauen welche Fehlernummer die Gegenstelle angibt. Da gibt es m.W. Fehler die einen erneuten Zustellversuch überflüssig machen.
    Bin jetzt bei deiner Fehlerbeschreibung davon ausgegangen, dass die Aufträge nachdem sie im Eingang auftauchten, nicht mehr im Transit stehen.

  • Quote

    @@wiederholung 250@@ steht vermutlich nicht in den Mails mit drin, daher wird es auf einen permanenten Fehler hinauslaufen den der empfangende SMTP dem Postman präsentiert. Daher mal im Monitor schauen welche Fehlernummer die Gegenstelle angibt. Da gibt es m.W. Fehler die einen erneuten Zustellversuch überflüssig machen.

    Es steht kein @@wiederholung 250@@ in den E-Mails mit drin.


    Es handelt sich lt. Status-Monitor nicht um einen permanenten Fehler. In meinem konkreten Fall war es ein: 451 temporary failure, server temporary busy.

    Quote

    Bin jetzt bei deiner Fehlerbeschreibung davon ausgegangen, dass die Aufträge nachdem sie im Eingang auftauchten, nicht mehr im Transit stehen.

    Richtig. Die E-Mails verbleiben dann nicht im Transit. Ein Versuch und das war es.

  • Ich habe da bei dir eine gaaaanz schlimme Vermutung. Fehler 451 der Gegenstelle bringt die Wahlwiederholungen nicht aus dem Konzept. Wenn du im Ausgang bei den Problem Mails mal in der Vorschau im Tab "Zusatzinfos" schaust, was siehst du da? Und wenn du im Client mal auf den Filter Button klickst (Das Trichter Symbol) und dann im zweiten Tab Optionen, ist da ein Haken vor "Nur Einträge mit Abschlussstatus"?

  • Ich habe da bei dir eine gaaaanz schlimme Vermutung. Fehler 451 der Gegenstelle bringt die Wahlwiederholungen nicht aus dem Konzept. Wenn du im Ausgang bei den Problem Mails mal in der Vorschau im Tab "Zusatzinfos" schaust, was siehst du da? Und wenn du im Client mal auf den Filter Button klickst (Das Trichter Symbol) und dann im zweiten Tab Optionen, ist da ein Haken vor "Nur Einträge mit Abschlussstatus"?

    Hi Wizzard,


    ich hatte Deine Nachricht gestern schon gesehen. Ich muss nur leider erst ein paar Themen wegen Datenschutz klären. Danach kann ich dir auch mal ein Protokoll von einem Kollegen zeigen.


    Nein, der Haken "Nur Einträge mit Abschlußstatus" ist bei uns nicht aktiviert.


    Unter "Zusatzinfos" kann ich mir ganz normal das Sendeprotokoll anschauen. Endet bei uns dann leider auf:

    Code
    (1) 250 2.1.5 Ok
    (1) DATA
    (1) 451 4.7.1 Service unavailable - try again later
    (1) SMTP Server: Data not ready!
    (1) RSET
    (1) 250 2.0.0 Ok
    (1) QUIT
    (1) 221 2.0.0 Bye
    (1) Mail Transmission aborted

    Es kommt ja sogar die Meldung "try again later" passiert aber nicht. Bleibt also wirklich bei einem einzigen Sendeversuch.

  • In Bezug auf Greylisting und entsprechend Ablehnung mit 451 hatte der David Postmaster schon immer Probleme bei uns, solche Empfängerdomains hab ich in der Vergangenheit dann immer in der Sende Methode Datenbank des Postman als zustellen über Smarthost eingetragen statt sie direkt zuzustellen und überlasse es unserem Provider sich damit herumzuschlagen.

    Greylisting ist in meinen Augen schlicht der größte Unfug den es gibt, die SPAM Bots haben längst gelernt damit umzugehen, es verhindert also genau nicht eine einzige SPAM Mail.

    Ich bin es daher schon seit Jahren leid da Zeit drauf zu werfen.
    Wer für seine Domains Greylisting aktiviert kommt bei mir entsprechend sofort in die Sende Methode Datenbank, die erhöhten Maillaufzeiten nehmen wir dann in Kauf.

    Allerdings haben wir da noch nicht mal ein dutzend Domains in der Datenbank welche diese Ausnahme benötigen. und das in über 10 Jahren.

    Valide andere Gründe für einen echten 451 welcher innerhalb einer vernünftigen Zeit noch zustellbar gewesen wären sind mir in all der Zeit nie untergekommen.
    Sowas kommt ja eigentlich auch nur bei tatsächlichen Serverausfällen vor und dann warnen uns die Kunden oder Lieferanten eh bevor wir Fehlermeldungen sehen auf anderen Kanälen.

  • Update:


    Also ein Teil des Problems ist nun weg. Nachdem der Dienstleister des Empfängers mal sein System kontrolliert hat, kommen nun auch nicht mehr diese Meldungen. E-Mails gehen wie gewollt raus.


    Generell hatte ich dieses Problem allerdings nicht nur bei einem Anbieter. Da ich allerdings vor kurzem zu viel an unserer Infrastruktur geändert habe, möchte ich hier nicht über Dinge in der Vergangenheit reden. Ich würde das ganze gerne nochmal im Auge behalten und mich dann nochmal mit aktuellen Logfiles zurück melden.


    Vielen Dank für die Unterstützung.

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!