Davids Service Layer - "Donut des Todes" ...

  • Hallo Community,

    trotz des neuen Servers (Dez 2019) läuft der Service Layer immer noch nicht ganz rund.

    Bei einigen Benutzern dreht sich der "Donut des Todes" (Windows 7 und 10, egal, welcher Stand), fast immer morgens,
    mal tagsüber und meist spät abends. Andere Benutzer können zeitgleich aber problemlos arbeiten.

    Starte ich den Service Layer neu durch, sind diese Probleme behoben, aber alle aktiven Benutzer sind auch kurz
    "abgeschossen" ...

    Bei alten Clients habe ich verwaiste Einträge zum alten Server vermutet (Prüfen aufd Updates), aber es tritt auch bei neu
    installierten Clients auf, auch Rechner ohne Virenschutz von Drittanbietern (nur Windows integrierter Standard).

    Auf Serverseite habe ich den Windows Defender deinstallert, um auszuschließen, dass Dateien mit fragwürdigen Inhalten
    durch Sicherheitssoftware blockiert werden.

    Ein Image des alten Servers habe ich als VHD gemountet, damit ich die 12,3 Mio Dateien nicht schaufeln lassen muss.
    Möglich, dass das die Bremse ist, wenn auf Inhalte hier drin zugegriffen wird.

    Nach wie vor betrifft es immer nur einzelne Rechner, nicht immer die gleichen und nicht nur Windows 7.
    Derselbe Benutzer auf verschiedene Geräten angemeldet hängt auf einem Gerät fest, kann im anderen aber arbeiten.

    Es gibt Tage ohne Störmeldung (oder die Benutzer haben sich bereits damit abgefunden) und Tage, an denen ich den SL
    mehrmals neu starten muss ...

    Auf dem alten Server (Win2K8 R2) war es zuletzt immer mal wieder so, dass der SL neue Verbindungen verweigert hat, bestehende
    Benutzerverbindungen aber arbeiten konnten.

    Ich habe allmählich keine Ideen mehr, was ich noch versuchen oder nachsehen könnte, außer den David durch eine andere
    Mailsoftware abzulösen ...

    *****

    Die VM läuft auf vmware ESxi 6.7 U3 Free Hypervisor, mit einem NFS Storageserver, alles mit 2x10 Gbit/s am Netzwerk angebunden
    und die Netzwerkadapter langweilen sich zu Tode ... also die Bandbreite kann es auch nicht sein ...

  • Hallo, was für ein Server ist den das auf dem ESX läuft?


    Wie sind die Einstellungen hier;

    ESXi UI => Host => Verwalten = Hardware => Energieverwaltung =>

    Steht hier "hochleistung" ?


    und was ich bei VMS auch schon als "Bremse" hatte war "Energiesparplan" den geändert auf Höchstleistung wirkten wunder.

    Tobit FX12 auf W2016 an VMWare ESXI6.5 Essentials,
    ActiveSync über Sophos SG210 /Reverse Proxy(WAF) - SMTP Proxy TLS

  • Der Server ist ein EPYC Rome 7282 mit 16 Core, 256G RAM.
    ESXi greift auf einen NFS Datenspeicher mit 26TB zu, der als FreeBSD-HAST mit CARP eingerichtet ist.

    Höchstleitung ist gesetzt, das ist das erste, was ich nach einer Installation des Basisbetriebssystems mache. ;-)

    Bei Windows Server steht der Energiesparmodus ja auch standardmäßig auf "Ausbalanciert" (oder so ähnlich). Und man benutzt einen Server ja (nach Ansicht von MS) nur von 8 bis 17 Uhr oder maximal 12 Stunden ... ;-)

    Statische Link Aggregation auf dem Switch, IP Hash basiertes Routing im vSwitch usw. ist eingestellt.
    Das Storage Netzwerk ist mit einem eigenen Kerneladapter vom VM Netzwerk abgetrennt.

    In der VM selbst ist auch Hardwarenahe Virtualisierung in den CPU Optionen gesetzt.

    Bei manchen Benutzern dauert es bis zu 25 Minuten, bis sie vernünftig im Client arbeiten können.
    Schneller natürlich mit Service Layer neu starten ...

    Andere VM habe ich auch getestet, die Antwortzeiten sind soweit normal, also dürfte das Storagesystem
    auch in Ordnung sein.

    Da nach dem neu starten des Service Layers keine Probleme mehr sind, denke ich das es eher am SL liegt, weniger an Windows oder dem anderen Unterbau ...

  • Moin, kommt bei uns jetzt auf einmal auch so.... der Client baut keine 267 Port Verbinmdung mehr auf...


    Programm DVWIN32.EXE, Version 12.0.0.8148 kann nicht mehr unter Windows ausgeführt werden und wurde beendet. Überprüfen Sie den Problemverlauf in der Systemsteuerung "Sicherheit und Wartung", um nach weiteren Informationen zum Problem zu suchen.

    Prozess-ID: 3378

    Startzeit: 01d5fb6e84372305

    Beendigungszeit: 13

    Anwendungspfad: C:\Program Files (x86)\Tobit InfoCenter\DVWIN32.EXE

    Berichts-ID: c9cea1be-6761-11ea-8ff5-1831bfcef0ae

    Vollständiger Name des fehlerhaften Pakets:

    Auf das fehlerhafte Paket bezogene Anwendungs-ID:

    09-f9-11-02-9d-74-e3-5b
    MfG Kingcopy seit C16 / C64
    Fachinformatiker / Systemintegration
    IT-Systemadministrator
    David (R) 2020 / 20 User / 500 GB
    David (R) 2020 / 150 User / 1,5 TB
    David (R) 2020 / 5 User / 15 GB
    d8-41-56-c5-63-56-88-c0

    Edited once, last by kingcopy ().

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!