Rollout 318 Volltextsuche SQL funktioniert nicht mehr

  • Hallo,


    obwohl ich nun schon zum x-ten Mal die SQL-Datenbank zurückgesetzt habe und den Vollindex neu aufgebaut habe funktioniert die Volltextsuche im David Client nicht mehr. Ich habe eine DAVID Standard-Installation also die DB unter DAVID\CODE.

    Die Datenbank ist da und läuft, in den DAVID\Ereignissen keine SQL Fehlermeldung.

    Das ging sicher noch vor ein paar Wochen, und an der Installation und am Client wurden NICHTS verändert.


    Kann jemand hier anleiten? Danke

    Regards/

    Frank


    PS:

    Tobit DAVID (since 1998):

    Born, raised up, collecting knowledge, getting wiser

  • Was meinen die mit Postfächer?

    Wenn ich alle Ordner reparieren muss 1482 Stück, na denn!??

    Regards/

    Frank


    PS:

    Tobit DAVID (since 1998):

    Born, raised up, collecting knowledge, getting wiser

  • Bei der Bereinigung wird ein Report erstellt, der wird, wenn es eingerichtet ist, an den Admin geschickt.

    Da sieht man, ob etwas mit der Archive.dat oder anderes "defekt" ist.


    Dies PF dann "reparieren". PURGE Report. bin nicht drauf gekommen ;-)

  • Danke für Deine Hinweise,


    und warum sollen jetzt plötzlich alle "Archive"/Ordner/Postfächer" defekt sein?

    Bei mir funktioniert die Suche plötzlich in keinem Ordner mehr?


    Was bedeutet jetzt bei Dir "Invalid Achive Path"?

    Wie konnte das bei Dir kommen, hast Du eine Erklärung?


    Mit aRCUTIL rum zumachen, hat in meiner Vergangenheit immer mehr kaputt (meistens Namen zerstört) , als besser gemacht.


    Danke für Deine Bemühungen.

    Regards/

    Frank


    PS:

    Tobit DAVID (since 1998):

    Born, raised up, collecting knowledge, getting wiser

  • Hallo


    So ich habe jetzt für einen Benutzer das ARCUTIL mit Reparatur von ARCHIV.DAT und ARCHIV.DIR ausgeführt.

    Ergebnis: keine falschen Pfade aber ca. 3500 wiederhergestellte Nachrichten als "ARCUTIL RECOVER"

    Das waren in der Regel alles Nachrichten, die bereits gelöscht waren,

    darauf hin habe ich die SQL DB zurückgesetzt und die Datenbereinigung gestartet, die SQL-DB wurde dabei neu aufgebaut.

    Nun habe ich den DAVID-Server neu gestartet und die Ereignisse kontrolliert => ALLES OK keine SQL Fehler.

    SQL DB sieht nun im Monitor so aus:



    So und die SQL-Volltext-Suche funktioniert immer noch nicht!


    Die Suchen kommen an



    Ich geb auf, verwende die alte SUCHE , auf der SSD wo DAVID installiert ist, ist das akzeptabel

    Regards/

    Frank


    PS:

    Tobit DAVID (since 1998):

    Born, raised up, collecting knowledge, getting wiser

    Edited once, last by mbkirk007 ().

  • Wenn's momentan eh nicht funktioniert, kannst du noch versuchen, die "David Archive Database" mittels SQL Management Studio zu löschen. Dann den SL neu starten, die DB sollte somit neu erstellt werden.


    Wie immer bei solchen Aktion der Dislaimer: Ohne Gewähr, und vorher Backup machen! ;)

  • Wenn's momentan eh nicht funktioniert, kannst du noch versuchen, die "David Archive Database" mittels SQL Management Studio zu löschen. Dann den SL neu starten, die DB sollte somit neu erstellt werden.


    Wie immer bei solchen Aktion der Dislaimer: Ohne Gewähr, und vorher Backup machen! ;)

    So .... auch das habe ich getan, keine Änderung!


    DAVID\Ereignisse meldet ordentlich:





    SQL_-Volltext-suche trotzdem immer noch ohne Funktion

    Regards/

    Frank


    PS:

    Tobit DAVID (since 1998):

    Born, raised up, collecting knowledge, getting wiser

    Edited once, last by mbkirk007 ().

  • Gleiches Problem bei unserer Installation seit Rollout 318.


    Die Suche(Filterung) "Finden" dauer unheimlich lange - der Client reagiert zeitweise nicht mehr...

    Teilweise habe ich dieses Verhalten "Client reagiert nicht mehr - Sanduhr bzw. Kreis dreht sich - bis zu 2 Minuten)" auch beim ersten Start des Client.


    Das Verhalten konnte ich nur bei ein paar Unsern feststellen - andere User haben noch nicht geklagt.


    Mit ARCUTIL habe ich meine eigenen Postfächer "korrigiert" - aber habe auch nur "gelöschte Mails" "gefunden".

    Danach auch die Datenbank mit "Datenbank zurücksetzen" neu aufgebaut...


    Das Problem tritt aber weiterhin sporadisch auf - meistens beim Suchen(Filtern) über die "Finden" Funktion im Client.


    Ich führe es auf das Rollout 318 zurück - zumindest hat es bei uns danach "angefangen"

  • Hallo


    Tobit hat mir geantwortet, ich solle den Sql server 2017 express installieren und eine neue David Instanz anlegen, die sich von der alten unterscheidet und diese solle ich dann verwenden.

    Regards/

    Frank


    PS:

    Tobit DAVID (since 1998):

    Born, raised up, collecting knowledge, getting wiser

  • Ich habe auch bei einer Installation so einem Problem, ich vermute jedoch, weil ich an den Windows "Rechten" herumgespielt habe, das irgendwo eine Berechtigung fehlt. Der genaue Datenfluss, welche Verzeichnisse im David Archive für die Suchergebnisse verwendet werden habe ich nicht ermitteln können. Es muss jedoch im Service Layer verarbeitet werden. Man kann ja die Archivrechte zurücksetzen, aber das macht ja auch viel Arbeit.

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!