Grabbing Dienst beendet sich ständig selbst

  • Hallo Tobit-Cracks,


    Wir registrieren bei mehrerer unserer Kunden in den letzten Tagen ein Phänomen, welches früher schon mal diskutiert wurde. z.B. hier im Forum oder hier.


    Das Problem ist, dass sich der Grabbing Server Dienst nach ein paar Sekunden Laufzeit von selbst beendet. Wir räumen dann streng nach Tobit Knowledgebase im Ordner \david\apps\dvgrab auf und starten ihn erneut. Dann ruft er wieder ab, und stürzt irgendwann wieder ab.


    Wir haben jetzt per Webmailer direkt beim Provider (Ionos) alle Postfächer leergeräumt und danach lief es wieder. Was uns zu der These bringt, dass es bestimmte Mails sein müssen, die den Absturz des Grabbing Servers verursachen. Vllt. Spam? Vllt. Viren/Trojaner?


    Was ich noch dazu sagen muss: Alle Kunden, die bislang bei uns betroffen sind, haben zwar David 3, aber nicht die allerletzte Version. z.B. hat einer diese hier im Einsatz: 12.00a - 2913


    Gibt es dazu schon neue Erkenntnisse? Oder haben vllt. Kollegen das Problem seit Kurzem auch wieder verstärkt? Ist euch ein Patch in einer aktuellen Version bekannt, der das Problem löst?


    Vielen Dank für alle erleuchtenden Beiträge!


    Gruß, Oliver

  • das Problem liegt eigentlich immer an einer defekten Mail auf dem Provider Server.

    Guckk in das Empfangsprotokoll, welche Mails der Grabbing Server bereits abgeholt hat, vergleiche das mit denen die noch beim Provider liegen und guck Dir dort dann nur die noch nicht abgeholten an, eine davon ist defekt bzw. enthält fehlerhafte Header Zeilen.
    Wenn Du glück hast erkennst Du die betreffende Mail sofort als SPAM und alles läuft wieder sobald du die SPAM Mails dort gelöscht hast.

    Um es etwas einfacher zu machen könnte man auch in den Einstellungen der abzurufenden Postfächer mal die Option Kopie aller Nachrichten auf Server belassen - welche viele angehakt haben - mal abstellen.

    Dann muss man künftig nicht erst noch gucken was der David bereits erfolgreich abgerufen hat und weiß in so einem Fall das alles was noch beim Provider im Postfach liegt verdächtig ist ;)

  • Danke, riawie, für deine Einschätzung. Problem bei uns ist, dass das Thema früher nie und jetzt bei mehreren Kunden in regelmäßiger Wiederholung alle paar Tage auftritt.


    Ist meine Annahme richtig, dass die Mail(s), an der/denen er letztlich scheitert, dann im Ordner

    David\Apps\Dvgrab\In liegen bleibt/bleiben, wenn der Grabbing Dienst sich beendet?


    Dann hätten wir ja einen Anhaltspunkt.


    Um es etwas einfacher zu machen könnte man auch in den Einstellungen der abzurufenden Postfächer mal die Option Kopie aller Nachrichten auf Server belassen - welche viele angehakt haben - mal abstellen.

    Das haben wir bei allen betroffenen Kunden bereits getan. Jedoch kommt es nach einigen Tagen wieder zu dem Problem. Anscheinend werden sie öfter mit solch fehlerhaften Mails beschossen.


    Wir updaten jetzt mal einen der betroffenen Kunden (kostenpflichtig) auf die neueste David Version. Dann werden wir sehen, ob sich die Probleme damit erledigen. Denn auffällig ist es ja schon, dass das Problem bei uns aktuell nur 4 Kunden betrifft, die alle noch mit alten David Versionen unterwegs sind.


    Ich werde berichten, ob's erfolgreich war.


    Gruß, Oliver

  • Hallo Oliver,


    bei uns ist da Problem gestern morgen zum ersten mal aufgetreten.


    Unser Tobit-Support hat das akt. ServiceRelaese installiert und danach lief es erstmal wieder. Gestern nachmittag wieder das gleiche Problem.

    Wir haben allerdings als Server OS noch Windows Server 2008R2.


    Gruß Berno

  • Mein Bauchgefühl sagt mir auch, dass da was im Busch ist. Aber noch weiß ich nicht warum. Vllt. liegt es daran, dass die Provider was geändert haben, oder Tobit muss seinen Grabbing Dienst mal wieder anfassen und verbessern.


    Wir werden sehen. Vllt. melden sich hier ja noch weitere Betroffene.


    Gruß, Oliver

  • Servus Oliver, servus beinander,


    ich habe das Problem des den Dienst quittierenden Grabbing Servers auch seit 2 Tagen. Neueste aktuelle Tobit Version 329. Vielleicht sogar, seit ich das letzte Tobit Update 329 installiert habe.

    Nach dem Neustart des Grabbing Server Dienstes läuft er wieder für einen halben Tag. Habe auch "auf dem Server belassen" angehakt.


    Hast du / hat jemand von euch Erkenntnisse? Wie habt ihr das Problem gelöst?


    Toberl

  • Servus Riawie,


    super, danke für die schnelle Info, liest du das "für die 329 gab es einen Hotfix wegen eines Problems mit dem Grabbing-Server" aus dem Changelog der neuen Version 330 heraus, oder wo finde ich bitte solche Informationen?


    Zwischenstand:

    das 330er habe ich noch nicht installiert, mache ich gleich, wohl aber ein paar Serverupdates Server 2012 R2, seitdem scheint der Tobit Grabbingserver wieder zu laufen.


    Gruß Toberl

  • super, danke für die schnelle Info, liest du das "für die 329 gab es einen Hotfix wegen eines Problems mit dem Grabbing-Server" aus dem Changelog der neuen Version 330 heraus, oder wo finde ich bitte solche Informationen?

    Das es einen Hotfix gab habe ich in diesem Fall schlicht im Forenthread hier zur 329 gelesen.
    Ansonsten kann man sowas aber jederzeit im David Administrator erfahren indem man auf dessen Hauptseite auf "Tobit Software Site Management" (linke Spalte unter Hilfen) klickt und dort dann unter Software > Downloads nachschaut welche Hotfixes es zur Zeit zum Download gibt.

  • Servus Riawie,


    danke, super, gfundn :-) ja, da war mal was..., hab mich nimmer erinnert...


    Ich hatte heute Vormittag die David Version 3.30 installiert, dennoch hat der Grabbing Server immer wieder den Dienst quittiert.


    Jetzt hab ich ganz frech den Grabbing Server Hotfix installiert, der ja eigentlich nur für 3.29 ist, mal sehen, ob es hilft....


    Hängt schon wieder :-(


    Toberl

  • Toberl Ich würde sagen da habt Ihr ein eigenständiges Problem und solltet mal eine individuelle Serviceanfrage bei Tobit aufmachen...

    https://tobit.software/davidSupport

    Unten auf der Seite: "Individuelle Unterstützung" klicken, dann "zum Support" klicken, anschließend anmelden (mit der zur Site gehörenden Chayns ID) und anschließend noch mal ganz unten auf "Individuelle Unterstützung" klicken, nun kann man auswählen ob man einen Rückruf möchte oder ob es auch der schriftliche Support tut ;)

  • Danke Riawe,


    habe ich gemacht, per Telefonanruf. Wir haben C:\David\Apps\Dvgrab\In geleert, da waren Dateien drin, die wollten sich nur widerständig entfernen lassen, aber dann doch.


    Und in C:\David\Import\System haben wir alle Dateien entfern, außer dem Ordner Objects.


    Und: Hilft nix.


    Bin gespannt, was Tobit morgen sagt. Habe noch eine David Sicherung vom 12.01. da könnte man für einzelne Ordner einen Fallback machen. Z.B. den ganzen Ordner Apps tauschen (12.01.2021 = 3.29, im Moment habe ich 3.30)


    Hauptsache, der Tobit "rennt" wieder brav, wie die letzten 7 Jahre.

  • Servus riawie, servus beinander


    habe jetzt das problematische APPs Verzeichnis umbenannt und durch das Verzeichnis aus meiner Sicherung vor 5 Tagen ersetzt. Da funktionierte der Grabbing Server noch.


    Das mit dem Tobit Support ist mühsam, weil, du hast am Anfang 10 Minuten Telefonat & Beratung, dann nur noch alle paar Minuten, auch mit längeren Pausen, einen Chat, bei einem Produktivsystem nix für die Nerven.

    Gibt es da bessere Supportmöglichkeiten, die natürlich auch teurer sind, wie z.B. den Jens Suing, was meint ihr?


    Toberl

  • Ich hab den Support immer nur schriftlich genutzt, nie telefonisch ;-)
    Ja, das ist problematisch für die Nerven, aber hey, ich hab ihn nur selten gebraucht bzw. wusste eh meist das es ein Bug ist den man meldet und dann auf ein neues Release wartet... weswegen man es am besten auch hier breit tritt, weils dann schon seinen Weg findet.
    Das was Ihr da habt ist natürlich nerviger als das was ich so hatte :o

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!