Grabbing Dienst beendet sich ständig selbst

  • Hallo Tobit-Cracks,


    Wir registrieren bei mehrerer unserer Kunden in den letzten Tagen ein Phänomen, welches früher schon mal diskutiert wurde. z.B. hier im Forum oder hier.


    Das Problem ist, dass sich der Grabbing Server Dienst nach ein paar Sekunden Laufzeit von selbst beendet. Wir räumen dann streng nach Tobit Knowledgebase im Ordner \david\apps\dvgrab auf und starten ihn erneut. Dann ruft er wieder ab, und stürzt irgendwann wieder ab.


    Wir haben jetzt per Webmailer direkt beim Provider (Ionos) alle Postfächer leergeräumt und danach lief es wieder. Was uns zu der These bringt, dass es bestimmte Mails sein müssen, die den Absturz des Grabbing Servers verursachen. Vllt. Spam? Vllt. Viren/Trojaner?


    Was ich noch dazu sagen muss: Alle Kunden, die bislang bei uns betroffen sind, haben zwar David 3, aber nicht die allerletzte Version. z.B. hat einer diese hier im Einsatz: 12.00a - 2913


    Gibt es dazu schon neue Erkenntnisse? Oder haben vllt. Kollegen das Problem seit Kurzem auch wieder verstärkt? Ist euch ein Patch in einer aktuellen Version bekannt, der das Problem löst?


    Vielen Dank für alle erleuchtenden Beiträge!


    Gruß, Oliver

  • das Problem liegt eigentlich immer an einer defekten Mail auf dem Provider Server.

    Guckk in das Empfangsprotokoll, welche Mails der Grabbing Server bereits abgeholt hat, vergleiche das mit denen die noch beim Provider liegen und guck Dir dort dann nur die noch nicht abgeholten an, eine davon ist defekt bzw. enthält fehlerhafte Header Zeilen.
    Wenn Du glück hast erkennst Du die betreffende Mail sofort als SPAM und alles läuft wieder sobald du die SPAM Mails dort gelöscht hast.

    Um es etwas einfacher zu machen könnte man auch in den Einstellungen der abzurufenden Postfächer mal die Option Kopie aller Nachrichten auf Server belassen - welche viele angehakt haben - mal abstellen.

    Dann muss man künftig nicht erst noch gucken was der David bereits erfolgreich abgerufen hat und weiß in so einem Fall das alles was noch beim Provider im Postfach liegt verdächtig ist ;)

  • Danke, riawie, für deine Einschätzung. Problem bei uns ist, dass das Thema früher nie und jetzt bei mehreren Kunden in regelmäßiger Wiederholung alle paar Tage auftritt.


    Ist meine Annahme richtig, dass die Mail(s), an der/denen er letztlich scheitert, dann im Ordner

    David\Apps\Dvgrab\In liegen bleibt/bleiben, wenn der Grabbing Dienst sich beendet?


    Dann hätten wir ja einen Anhaltspunkt.


    Um es etwas einfacher zu machen könnte man auch in den Einstellungen der abzurufenden Postfächer mal die Option Kopie aller Nachrichten auf Server belassen - welche viele angehakt haben - mal abstellen.

    Das haben wir bei allen betroffenen Kunden bereits getan. Jedoch kommt es nach einigen Tagen wieder zu dem Problem. Anscheinend werden sie öfter mit solch fehlerhaften Mails beschossen.


    Wir updaten jetzt mal einen der betroffenen Kunden (kostenpflichtig) auf die neueste David Version. Dann werden wir sehen, ob sich die Probleme damit erledigen. Denn auffällig ist es ja schon, dass das Problem bei uns aktuell nur 4 Kunden betrifft, die alle noch mit alten David Versionen unterwegs sind.


    Ich werde berichten, ob's erfolgreich war.


    Gruß, Oliver

  • Hallo Oliver,


    bei uns ist da Problem gestern morgen zum ersten mal aufgetreten.


    Unser Tobit-Support hat das akt. ServiceRelaese installiert und danach lief es erstmal wieder. Gestern nachmittag wieder das gleiche Problem.

    Wir haben allerdings als Server OS noch Windows Server 2008R2.


    Gruß Berno

  • Mein Bauchgefühl sagt mir auch, dass da was im Busch ist. Aber noch weiß ich nicht warum. Vllt. liegt es daran, dass die Provider was geändert haben, oder Tobit muss seinen Grabbing Dienst mal wieder anfassen und verbessern.


    Wir werden sehen. Vllt. melden sich hier ja noch weitere Betroffene.


    Gruß, Oliver

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!