Services werden nach einem Reboot nicht gestartet

  • Nabend,

    ich habe das Problem, dass nach einem Server-Reboot ( Windows Server 2019 ) mit aktuellsten Updates nach einem Reboot die Services nicht gestartet werden.

    Zum Beispiel 'SQL Server (DAVID)', 'SQL Server CEIP service (DAVID)', 'David WebApi', 'David Service Layer' und 'David WebBox' werden sofort beendet bzw. gar nicht erst gestartet.

    Ich muss diese immer manuell starten, dann laufen sie auch und bleiben so - bis zum nächsten Reboot / Update von Windows.

    Vorher war das nicht so!

    Daher kommt auch der ständige Fehler, dass die Clienten den Server nicht mehr finden und dann ist hier immer Alarm!


    Weiß jemand, woran das liegt und wie ich den Fehler beheben kann?

    Was ich dazu sagen muss, der DAVID-Server läuft auf einer Proxmox-VM und wenn ich den Proxmox-Host neu starte, tritt dieser Fehler auf. Ich muss dann entweder die VM seperat neu starten oder eben die Dienste manuell starten. Dann klappt alles, aber das kann ja so nicht richtig sein. Und die VMs werden vor dem Reboot des Proxmox-Host alle ordnungsgemäß heruntergefahren und nach dem Reboot wieder automatisch neu gestartet.


    Bin jetzt nicht so scharf drauf, den David-Server neu aufzusetzen, weil ansonsten alles läuft - nur eben der Mist mit den Services nach einem Reboot nicht. Und ja, die Startvariante steht auf 'Automatisch', NICHT auf Verzögert!



    Danke schon mal für eure Hilfe!

  • Da wird wohl nur ein Blick in die Ereignisprotokolle helfen. Irgendwelche Abhänigkeiten noch nicht erfüllt? Versucht Windows, die Dienste zu starten, ehe DNS & Co. korrekt laufen? Was ist das denn für ein System - Member-Server in einer Domäne?


    Wenn die Ursache nicht klar wird, würde ich einfach ein Script basteln und darin per NET START die Dienste manuell ankurbeln. Das dann per Aufgabenplanung 3 Minuten nach dem Booten anstoßen - so wird dir zumindest der Teil des manuellen Eingriffs abgenommen. ;) Nicht schön, aber Windows Server ist halt manchmal launisch.


    Konkret diesen Fall hatte ich persönlich übrigens noch nicht, aber beim letzten Reboot unseres eigenen David-Servers lief anschließend der SQL-Server nicht. Das haben wir damals gedanklich abgehakt, weil es eine ziemlich alte Kiste ist (mit Server 2012R2), alle David-eigenen Dienste waren gestartet.

  • kann ich bestätigen, besonders in virtualisierten Umgebungen, aber auch in machen aktuellen physischen Umgebungen sollte man die Dienste auf verzögerten Start setzen damit sie zuverlässig beim Systemstart hoch kommen.

  • Herzlichen Dank!
    Zum Mindest findet er nach einem Reboot den Server wieder, da der David Service Layer nun später gestartet wird. Der DAVID SQL-Server jedoch weiterhin nicht, aber es scheint trotzdem alles zu laufen.

  • ChrisRE84 Der SQL Server ist für die Suche und den Chat notwendig, wenn er nicht gestartet wird läuft also entsprechend nicht alles, es ist Dir scheinbar nur noch nicht aufgefallen was in der Situation nicht funktioniert.

    Ich lasse in solchen Umgebungen den SQL Server und den David Service Layer auf Startmodus Automatisch und stelle nur die restlichen David Dienste auf verzögerten Start.
    Letztlich muss man es ausprobieren was am zuverlässigsten funktioniert.

    Notfalls eine Batch Datei schreiben welche über den Taskplaner beim Systemstart ausgeführt wird, sich dann erst mal eine gewisse Zeit schlafen legt und dann alle notwendigen Dienste prüft und fehlende startet, oder falls einem die Kenntnisse zum prüfen fehlen halt schlicht in definierter Reihenfolge beendet um sie dann in ebenso definierter Reihenfolge und mit gewissen Pausen zwischendurch wieder neu zu starten. Letzteres ist natürlich der harte Weg durch den Garten, aber angesichts dessen das so ein Server ja in aller Regel nur selten neu gestartet werden dürfte zumindest mal eine Versicherung dagegen das man hinterher vergisst sich um die eigentlich bekannten Probleme zu kümmern ;)

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!