Warum wird die interne IP des Mailservers in den Header eingetragen

  • Hallöchen,


    kann mir jemand erklären, warum David seine interne IP in den Header der ausgehenden Mails schreibt?

    Der Server sendet seine Mails nicht direkt sondern nutzt einen Smarthost.


    Grüße aus dem tiefen Süden.

  • Die aller erste Received Zeile kommt vom David und die muss auch vom David kommen, weil das halt den gültigen RFCs entspricht und der David sich halt RFC Konform verhalten soll ;)
    Deswegen steht dort bei auch jedem Mailserver erst mal die eigene IP Adresse drin.
    Man kann das allerdings bei verschiedenen Mailservern umkonfigurieren, so das dort entweder keine oder eine andere IP Adresse drin steht.
    Beim David Server ist mir allerdings keine Möglichkeit bekannt das Verhalten zu ändern.
    Viele entfernen diese interne IP-Adresse - oder generell alle internen IP-Adressen - halt auch mittels ihrer transparenten Proxys an der Grenze zum öffentlichen Netz. Und das nicht nur wenn da ein David drinnen steht ;)

  • Hallo,

    bei mir wird es ausgeblendet bzw. verborgen.

    Das macht der davor also vor dem Tobit liegender NoSpamProxy,


    Bei ausgehenden Mails, gibt s eine Aktion,

    Verberge Topologie des Unternehmens

    so ist die erste IP der NoSpamproxy gegenüber dem ersten mail Server.


    Grüße

    Tobit FX12 auf W2016 an VMWare ESXI6.5 Essentials,
    ActiveSync über Sophos SG210 /Reverse Proxy(WAF) - NoSpamProxy Mail Security

  • Guten Morgen,


    Meint ihr die Zeile "Received: from David.Server [interne IP]" ?
    Die wird in der Regel vom ersten beteiligten SMTP Server eingesetzt, nicht vom Postman.

    Genau die. Allerdings steht da auch noch die externe IP.


    Received: from [192.168.0.145] (unknown [xx.xxx.47.8])


    Dann wäre ein Proxy mal eine Maßnahme.


    Danke Euch für die Tips/Info.

  • Eine andere Maßnahme wäre, in der Postman.ini EHLOWITHDOMAIN = TRUE einzutragen.

    Was allerdings nichts dran ändern wird das der David Postman weiterhin seine interne IP Adresse in die erste Received Zeile schreibt,
    Denn die Einstellung EHLOWITHDOMAIN bestimmt nur wie sich der David Server gegenüber externen smtp Servern melden wenn er dort mails einliefert:


    Code
    EHLOWITHDOMAIN = TRUE
    ;  Default = FALSE
    ;  Specifies which reply is to be given by PostMan to the EHLO/HELO SMTP command
    ;  when sending eMails via a provider. When set to FALSE PostMan will return the
    ;  local IP Address of the DvISE server. When set to TRUE PostMan will use the
    ;  domain name entered as "SMTP Host Name" in the PostMan system configuration.


    Die allererste Received Zeile allerdings generiert der David Server selbst wenn er die Mail vom David Client bekommt noch bevor er sie überhaupt nach außen weitergibt.

    Diese Zeile wird zwar nur bei an extern versandten Nachrichten erzeugt, aber sie wird intern erzeugt bevor die Nachricht an den Provider geht:

    Code
    Received: from $smtp.host.name$ [$internal_ip$] by $smtp.host.name$ with david3 by Tobit.Software ($numeric.Msg.ID$); 20 Jan 2022 17:41:05 UT

    An stelle von $smtp.host.name$ steht dort dann halt was man in der Konfiguration des Postman im Feld "SMTP Host Name" eingetragen hat und $internal_ip$ ist immer die interne IP Adresse des David Servers bzw. eine der internen IP Adressen falls er mehrere hat.

    Erst die nächste Received Zeile wird vom Provider an welche der David Postman die Mail übergibt erzeugt und erst dort hat die obige Einstellung eine Auswirkung.

  • Ah, sie mal einer Guck, ich hatte mich schon gewundert warum Du die Zeile scheinbar nicht hattest oder sie übersehen hast.
    Ich hatte entsprechend schon erwartet das Du irgendwann noch mit irgendwas um die Ecke kommst wie man diese erste Zeile verhindern kann.
    Was dann ja jetzt auch in gewissem Sinne der Fall ist, wenngleich das - zumindest hier - jetzt eher keine Option ist.

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!