David frisch installiert - holt keine Mails

  • Hallo Freunde,


    da die vorige Installation nicht funktionierte habe ich David frisch und neu installiert, dann die Benutzer angelegt - samt E-Mailadressen. Doch die Mails werden nicht geholt obwohl auf dem Server Mails von mehreren Jahren vorhanden sind. Sie werden einfach nicht geladen.


    Gehe ich im Admin unten auf POP3 Postfächer und will eines öffnen kommt die folgende Fehlermeldung (siehe screenshot).

    Weiß jemand den Grund dafür? Früher konnte ich beim Grabbing Server alle Benutzer anklicken und ihre Postfächer auf Verbindung testen. Jetzt nicht mehr. Natürlich bin ich auf dem Server und als Administrator unterwegs.

  • Ok, habs gemacht. Jetzt scheinen die Postfächer richtig zu sein. Habe den Server neu gestartet. Doch ein Dienst startet nicht und somit kommen dennoch keine Mails an.


    Der SQL Server CEIP service von David startet nicht

    Code
    SQL Server CEIP service (david) SQLTELEMETRY$DAVID
  • In der Ereignisanzeige findet sich folgendes:

    Ereignis ID 7000, Quelle Service Control Manager

    "Der Dienst "SQL Server CEIP service (DAVID)" wurde aufgrund folgenden Fehlers nicht gestartet:

    Das System kann die angegebene Datei nicht finden."

    Der Dienst DAVID SQL SERVER läuft auch nicht und lässt sich nicht starten. Also das ist was ich schon vorher hatte.

  • In der Ereignisanzeige findet sich folgendes:

    Ereignis ID 7000, Quelle Service Control Manager

    "Der Dienst "SQL Server CEIP service (DAVID)" wurde aufgrund folgenden Fehlers nicht gestartet:

    Das System kann die angegebene Datei nicht finden."

    Der Dienst DAVID SQL SERVER läuft auch nicht und lässt sich nicht starten. Also das ist was ich schon vorher hatte.

    Auch steht eindeutig "Das System kann die angegebene Datei nicht finden."
    Ich würde da den SQL nochmal drüber istallieren

  • Der SQL Server CEIP service von David startet nicht

    Wie schon im Nachbarthread beschrieben, ist das zwar unschön und sollte behoben werden. Aber David holt auch ohne SQL Mails ab. Der SQL ist nur für "Nebenschauplätze" wie Suche, Chat usw. da.


    Wenn die POP3-Postfächer jetzt schön unterhalb des Grabbing Servers eingerichtet wurden, muss dort auch noch eine regelmäßige Abholung konfiguriert werden: Rechtsklick auf "Grabbing Server - POP3 Dienst" -> Konfigurieren -> Reiter "Verbindung" -> "Postman-Einstellungen benutzen" deaktivieren (wenn, wie ich vermute, du die Mails immer bei Bedarf über einen Smarthost versenden willst) und unter "Aufbau" z. B. "alle 2 Minuten" einstellen. Vielleicht zusätzlich noch einen Haken bei "Nach Programmstart verbinden", dann holt David bei jedem Neustart des Dienstes.


    Anschließend (bzw. nach spätestens 2 Minuten) sollte sich das Eingangsprotokoll füllen.

  • Wobei, was mir gerade noch einfällt: Wieso eigentlich SQL CEIP? CEIP ist doch dieses komische Kundenfeedback-Modul, oder? Wo kommt das denn eigentlich her? Hast du den SQL-Server manuell aufgesetzt?

    Hallo nordtech,
    nein ich habe alles nur von der ISO installiert und nur E-Mail gewählt. Ich schaue rein ob Deine Ratschläge was bringen.

  • Warum? Macht der Postman irgendwas anderes als Mails sofort über den Provider (Smarthost) zu schicken? Wenn nicht, ist die Aktivierung der Option an der Stelle falsch.

    Ok, dann war es die "Aufbau" Einstellung. Ich deaktiviere die andere Option wieder.

  • Warum? Macht der Postman irgendwas anderes als Mails sofort über den Provider (Smarthost) zu schicken? Wenn nicht, ist die Aktivierung der Option an der Stelle falsch.

    DIe Mails sind geladen. Doch leider hat der Server diese vom Server geholt und dort gelöscht da ein Häkchen bei den Postfächern fehlte. Gibt es eine Möglichkeit die Mails wieder dorthin zu schieben?

  • Um die Mails wieder beim Provider zu haben fallen mir nur ein:


    - Backup vom Provider einspielen falls vorhanden

    oder

    - z.B. Thunderbird installieren und die Postfächer mit IMAP vom Provider anbinden, dazu die gleichen Postfächer von david in Thunderbird einbinden und dann copy&paste.

    - ggf. mit drag&drop probieren.

  • Ok, ich habe aber jetzt noch ein Problem festgestellt.

    Der David hat ja alles runtergeladen und beim Hoster/Provider gelöscht. Jetzt sind alle Mails auf dem Server, aber die Ordnerstruktur wurde nicht mitgeladen und damit sind all diese Mails unsortiert.

    Wie ist das möglich und was kann ich da tun?

  • David sortiert eingehende Mails anhand der E-Mail-Adressen, die bei den Benutzern eingetragen sind. Holt man per POP, ist es sinnvoll, in den Eigenschaften der Postfächer zusätzlich den Provider-Header auszuwerten, also z. B. das Feld "X-Original-To:", damit Rundsendungen nicht mit zusätzlichen Kopien im "Unverteilt" landen.


    Oder meinst du, dass bei den Usern providerseitig Ordner unterhalb des Posteingangs angelegt waren, und diese sich nicht im David wiederfinden? Dann ist die Antwort einfacher: David ist kein IMAP-Client, wo die Ordnerstruktur 1:1 erhalten bleibt. David holt per POP3 und schmeißt alles in ein zentrales Archiv. Die Sortierung/Unterteilung beim Provider und in David sind vollkommen unabhängig voneinander.

  • Oder meinst du, dass bei den Usern providerseitig Ordner unterhalb des Posteingangs angelegt waren, und diese sich nicht im David wiederfinden? Dann ist die Antwort einfacher: David ist kein IMAP-Client, wo die Ordnerstruktur 1:1 erhalten bleibt. David holt per POP3 und schmeißt alles in ein zentrales Archiv. Die Sortierung/Unterteilung beim Provider und in David sind vollkommen unabhängig voneinander.

    Ja, genau das meinte ich. Ok, das vertehe ich natürlich jetzt mit den Ordnern. Doch kann man irgendwie diese Verzeichnisse wiederherstellen ausser per Hand?

    Jetzt gibt es noch zwei Probleme seitens des Servers:
    - die SQL Dienste von David die nicht laufen (versuche ich am WE zu beheben)
    - der Client auf dem Server startet gar nicht. Kommte ne Fehlermeldung. Momentan kann ich die nicht benennen denn ich bin unterwegs und habe keinen Zugriff.

  • Doch kann man irgendwie diese Verzeichnisse wiederherstellen ausser per Hand?

    Nein, David weiß eingehend von IMAP-Ordnern nichts, das muss man in der Tat "zu Fuß" machen. Alternativ mit einem IMAP-Client (z. B. Thunderbird), und dann mit einem Tool wie Mailstore die Daten übernhemen. Dazu müssten aber die Nachrichten zunächst wieder korrekt sortiert zum Provider zurück geschaufelt werden.

    der Client auf dem Server startet gar nicht

    Zu allererst versuchen, den Client nochmal drüber zu installieren, einfach die Setup.exe aus dem "Clients"-Verzeichnis starten und durchklicken. Aus David-Sicht handelt es sich bei der Server-Installation um ein ganz normales Client-Setup.

  • Nein, David weiß eingehend von IMAP-Ordnern nichts, das muss man in der Tat "zu Fuß" machen. Alternativ mit einem IMAP-Client (z. B. Thunderbird), und dann mit einem Tool wie Mailstore die Daten übernhemen. Dazu müssten aber die Nachrichten zunächst wieder korrekt sortiert zum Provider zurück geschaufelt werden.

    Zu allererst versuchen, den Client nochmal drüber zu installieren, einfach die Setup.exe aus dem "Clients"-Verzeichnis starten und durchklicken. Aus David-Sicht handelt es sich bei der Server-Installation um ein ganz normales Client-Setup.

    IMAP - na ich habe schon alles auf David wiederhergestellt. Doch da es ein POP3 System ist gibt es kein "hochschaufeln". Ich würde gerne die Ordnerstruktur mit drag & drop von David Client zu Thunderbird rüberziehen, doch es hat sich herausgestellt, dass man das nur mit den Nachrichten, aber nicht mit der Verzeichnisstruktur machen kann. Da siehe ich nur das Kreis mit dem Querbalken drinne anstatt des Mauszeigers wenn ich es versuche zu ziehen. Also gesperrt/nicht möglich.

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!