Posts by hiroprotago

    Moin,


    wie schützt Ihr Eure David Server Systeme?


    Ich nutze u.a. NAS Systeme, die sehr gut die Angriffe dokumentieren. Nun frage ich mich in wie weit die beste Lösung für ein Windows Server System aussehen.


    Aktuell nutze ich Serverschutzsoftware von Kaspersky und zudem Sitecare von Tobit, erstelle regelmäßig Images und halte das System aktuell. Aber reicht das bzw. was ist überhaupt notwendig?


    Danke für hilfreiche Beiträge 8)

    Ok, Tobit hat mir auch geschrieben.

    Sie würden den IIS sehen und den solle ich deaktivieren, wenn ich ihn nicht benötige.

    Habe ich gemacht und nun kommt nach der Zertifikatsanforderung was Neues:


    Fehler bei Verarbeitung des Auftrags (Failed to validate DNS-records (A, CNAME), Invalid domain provided)


    Ich bin in die DNS Einstellungen des Providers und habe CNAME auch auf die ÖIP umgestellt.

    Ja Danke!

    Ich hatte nur den Port 80 geroutet, nach dem ich den Bereich auf Port 81 erweitert habe, klappt der Test auf diesem Port. Jedoch klappt es nicht mit dem Zertifikat: Hier kommt die Meldung "Ungültiger Domainname"


    Gebe ich den Domainname im Browser ein, kommt eine 404 Fehlermeldung des Servers

    "Datei oder Verzeichnis wurde nicht gefunden"

    Gebe ich die öffentliche IP ein, lande ich auf der IIS Webseite des Servers.


    In der Firewall sind alle David Module auf allen Ports freigegeben.

    Ich habe mal die Firewall deaktiviert und das Zertifikat angefordert. Hier kommt dann "Fehler bei der Verarbeitung des Auftrags, Failed to connect WebBox.."

    Auch nach Neustart der WebBox das Gleiche..


    Der David Client über 267 funktioniert problemlos.



    Beste Grüße

    Moin und vielen Dank!

    Ich war leider krank und konnte mich bis heute nicht mehr kümmern und dazu melden.


    Leider funktioniert(e) es nicht. Folgendes habe ich durchgeführt

    1. Anlegen einer Subdomain (ionos)

    2. A Einträge in der DNS Konfiguration bei IONOS auf die fest ÖIP umgestellt

    3. Fritz Router Portfreigabe für Port 443 auf den David Rechner (Windows Server) eingestellt

    4. Fritz Router Portfreigabe für Port 80 auf den David Rechner (Windows Server) eingestellt

    5. Im David Admin den Dienst Webbox starten und auf automatischen Start gestellt

    6. Im David Admin unter "TLS-Verschlüsselung", "Neues Zertifikat anfordern" versucht ein Zertifikat anzufordern

    Das Zertifikat konnte nicht angefordert werden.

    7. Domain und Adresse eingetragen und Übertragung getestet


    Was bedeutet Falsches Modul?


    Unter TLS Zertifikate sind mehrere Zertifikate eingetragen

    mail, postman, webAPI und webBox

    Nur unter webAPI steht eine lange Gültigkeitsdauer. Ich vermute das entspringt den ersten Versuchen mit der API für den Smartclient und ist das selbst erstellte Zertifikat.


    Kann ich die beiden Einträge für webBox und webAPI problemlos löschen?


    Danke und viele Grüße

    Nachträgl. frohes Neues!

    Moin, ja sorry.. vollkommen richtig


    Ich wollte ja eine grundsätzliche Anleitung, damit ich mich so durchwuseln und alles mal ausprobieren/testen kann.


    Der erste Mitarbeiter seitens Tobit hat nicht erwähnt, dass der SmartClient Kalender nicht kann.

    Dann wird es vermutlich Active Sync. Trotzdem wollte ich mal alles durchgehen und mir das anschauen, eben auch den Smart Client.


    Nach der Tobit Anleitung, habe ich mich der WebAPI gewidmet und bin dort auf den Domain Name gestoßen. Ich habe dort einen freien Domainnamen eingetragen und den AAAA Eintrag in den DNS Einstellungen beim Provider (IONOS) auf die IP des Routers eingestellt. Zudem den Port 8443 im Router auf den Server geroutet. Nur um zu testen dann eben das selbst signierte Zertifikat eingerichtet und angegeben. Die Prüfung der Erreichbarkeit in den Einstellungen der WevAPI führt zu einer Fehlermeldung:

    1. Der angegebene Name passt nicht zum Zertifikat

    2. Die david WebAPI antwortet nicht korrekt

    Ursachen Dienst nicht gestartet oder Port belegt

    (ist gestartet und der Port nicht belegt)

    3. Es konnte keine Verbindung hergestellt werde


    - David Version? Tobit David3

    - Sitecare? ja

    - Webbox schon in Betrieb? nein

    - Smartclient? ja, geht jedoch nicht

    - Internetzugang (feste IP, Dyndns, Router)? feste IP ja, DynDNS nein, Router ist eingestellt

    - Firewall? eingestellt

    - SSL-Zertifikat? ein selbst signiertes Zertifikat fürs Erste


    Also von mir aus EAS

    Was müsste ich tun?


    Danke übrigens..

    Moin,


    ich würde gerne E-Mails und Kalender auf einem Smartphone mit Android 10 und einem iPhone realisieren.


    Ich habe mir hier schon einen Wolf bzw. immerhin ein Wölfchen gesucht und finde keine komplette Anleitung, die tatsächlich alles beschreibt

    1) Einstellungen am Server

    - Zertifikat einrichten und einbinden

    - Domain verbinden

    - Allgemeine Einstellungen

    2) Einstellungen am Router

    - Portfreigabe

    3) Einstellungen am Smartphone


    Vielen Dank für jeden Hinweis..

    David3 soll über die david WebAPI (smart client) via Smartphone erreichbar sein.

    Kann mir dazu bitte mal einer auf die Sprünge helfen?


    Ich benötige einen Domain Name, mit dem der David extern erreichbar sein muss, kann mir aber darunter nichts vorstellen..

    Welche Wege gibt es um das zu bewerkstelligen und gibt es Anleitungen dazu?

    Kann ich eine Domain bei einem Hoster wie Strato mit dem David verbinden?


    Grundsätzlich habe ich einen Windows Server 2019 Standard, eine Fritz.Box mit fester IP, den Port 8443 für die WebAPI freigegeben und eine ChaynsID.




    Danke für jegliche Hilfe!

    Moin Moin,


    ich habe ein paar Projekt-Verzeichnisse im David angelegt und eben dort als Unterverzeichnisse u.a. Posteingang und Postausgang.


    Füge ich nun eine Spalte in einem Verzeichnis hinzu, passiert das in allen Verzeichnissen, ebenso wenn ich eine Spalte entferne, ist die in allen Verzeichnissen futsch.


    Woher kommt das nur und wie kann ich das verhindern?


    Windows Server 2008 R2
    David FX 2012 12.00a - 2641
    Benutzer haben auf Dateiebene alle Rechte auf die Verzeichnisse




    Vielen Dank und beste Grüße 8|

    Moin Moin,


    folgendes mystisches Erscheinungsbild:


    Alle Benutzer im David werden im Chat angezeigt, obwohl einigen das Recht zum Chat genommen wurde.
    Kann man Benutzer im Chat unsichtbar machen?


    Im Chat kann eine Gruppe angelegt werden. Es können Teilnehmer hinzugefügt werden, jedoch nicht entfernt werden.
    Kann man Benutzer irgendwie aus einer Gruppe löschen ohne die ganze Gruppe zu löschen?


    In einer alten David.fx 2012 Version wurden die Chats im Postausgangsverzeichnis abgelegt.
    Wo werden in der aktuellen Version David(r) die Chats und die Gruppen gespeichert?



    Mir scheint der Teamchat bei David ist ähnlich der Medienwiedergabe programmiert. Funktioniert, aber eben auch nicht. Tobit teilte mir dazu mit, die Medienwiedergabe wird derzeit nicht weiterentwickelt. Ich fand sie ganz gut, weil sie extern liegende MP3s wiedergeben kann, diese aber nicht in die richtige Reihenfolge bringt.


    Danke für jeden Hinweis 8o


    Servus, Warum? Weil damit meist FEHLER behoben werden ;)


    *moep*


    Hallo nochmal.
    Welche Fehler wurden behoben? Eine Liste wäre cool.
    Ich installiere und arbeite mit David seit David10.


    Fehler gab es nie, jedenfalls keine die bei Arbeit auffielen.
    Fehlende Funktionen dafür mehr.


    Wenn die dann nach einem Update plötzlich da wären, wenn man dann noch danach sucht, ok.
    In der aktuellen Version kann man einen Termin im Kalender "absagen" und damit durchstreichen. Überlegt man es sich anders, kann man den durchgestrichenen Termin leider nicht wieder aktivieren. Löschen und neu schreiben ist angesagt..



    Beste Grüße

    Hallo,


    ich kann mit David (R) einen Textbaustein erstellen und dort einen @@von Kommando einsetzen.
    Ich öffne dann eine neue Mail, füge den Textbaustein ein und die Mail wird über das Kommando versendet.



    Nun wollte ich in den Textbaustein noch eine Rundsende-Liste einfügen und abspeichern, damit die Mail immer an die eingetragenen Adressen versendet wird, ohne das noch die Rundsendung einfügen muss. Also einen Schritt sparen.
    Die Rundsendung geht raus, wenn ich sie über das Menü eingebe.


    Leider geht die Mail aber nicht raus, wenn ich die Rundsendung im Textbaustein abspeichere...
    @@von meineadresse@@
    @@RUNDSENDUNG NEWS.RND@@



    Hat jemand eine Idee aus welchem Grund?



    Vielen Dank für Tipps






    Hinweis:
    Folgende Funktionen klappen auch nicht


    Weiterleitung an mehrere Empfänger (Mailingliste)
    Q-104.225



    Nachrichten mit »Weiterleitung und XMedia« an mehrere Empfänger schicken
    Q-107.646

    (ist ohnehin unvollständig beschrieben)

    Hallo,


    hat jemand Erfahrungen mit dem "eingeschränkten Modus" bei langsamer LAN Verbindung?


    Ich habe im Netzwerk einen Client, der nach einer kurzfristigen LAN Überlastung, den Client immer noch im eingeschränkten Modus laufen hat. Mir begegnet dieses Phänomen tatsächlich nach einigen Jahren zum ersten Mal und ich finde verteufelt wenig im Netz, hier oder der Knoweledgebase.


    Ich suche praktisch eine Möglichkeit diesen Modus manuell zu deaktivieren.
    Geht das überhaupt?


    Besten Dank für hilfreiche Hinweise und Grüße ins Forum


    Hiro


    David (R) Pro auf Win 2012 R2

    Hallo..,


    aus welchem Grund seit Ihr so heiß auf Updates?


    Meine Kunden verlangen das eigentlich nie.
    Ich selbst teste Updates auf Testservern und haue sie dann erst raus.
    Ich setze mir den eigenen PatchDay.


    Nur gibt es denn bahnbrechende Verbesserungen?


    Ich frage mich immer wieder ob diese Verbesserungen nicht vielmehr dem Softwareunternehmen dienen.



    BG
    Hiro