Posts by graef-edv

    Moin.

    Bei mir standen heute morgen alle David-Dienste auf "Beendet". Nach einem manuellen Start läuft aber bisher alles problemlos. Irgendwie hat das Update wohl vergessen, die Dienste wieder zu starten.


    Viele Grüße, Jörg.

    Moin.

    Die Deutsche Glasfaser bietet keine öffentlichen IP-Adressen an, sondern nutzt Adressen aus dem Bereich 100.64.0.0 bis 100.127.255.255. Hierbei handelt es sich um ein Carrier-Grade-NAT, welches nicht aus dem Internet routbar ist.

    Meines Wissens gibt es öffentliche IP-Adressen nur bei Business-Verträgen ab ca. 300 Euro/mtl.

    Es gibt allerdings Anbieter, die Bridges betreiben und dann einzelne TCP-Ports für ca 10 Euro pro Monat vermieten.


    Viele Grüße, Jörg.

    Hallo,


    bei einem Kunden habe ich folgende Situation:


    Der Kunde hat einen Zentralkalender (DavidRoot/Zentralkalender). Dieser Kalender ist im persönlichen Kalender eingeblendet, wenn ein neuer Termin erstellt wird kommt beim Abspeichern der Dialog, in dem man den Zentralkalender als Speicherort auswählen kann. Alles funktioniert einwandfrei.


    Kommt nun eine Termineinladung per Mail ( in einen Gruppenordner, DavidRoot/Gruppen/Funktionspostfach) kann diese zwar angenommen werden, als Speicherort wird aber nur der persönliche Ordner und der Feiertagsordner angezeigt.


    "Bis vor kurzem" war es hier möglich, auch den Zentralkalender auszuwählen.


    Hat jemand eine Idee, wie ich hier den Zentralkalender wieder zur Auswahl hinzufügen kann?


    Viele Grüße, Jörg.

    Moin Moin,


    ich hänge mich hier einmal mit dran, da ich exakt das gleiche Problem ebenfalls bei einem Kunden habe.

    Ich nutze bei diesem Kunden ebenfalls seit Jahren DriveSnapshot zur Datensicherung, das Problem tritt aber erst seit einigen Monaten auf. Der David-Server läuft auf einem Windows Server 2008R2.


    Wenn der Service-Layer hängt stürzt der Infocenter auf den Client-PCs ab und lässt sich nicht mehr starten. Dies tritt oftmals morgens auf, immer wieder aber auch mitten am Tag, also definitiv unabhängig von der Datensicherung. Der David Client lässt sich dann nicht mehr öffnen, es passiert nichts, wenn man ihn doppelklickt. Manchmal geht der Davic-Client noch, dopellt geklickte Mails bleiben dann allerdings leer.


    Schieße ich den SL mit taskkill ab, so startet er sich umgehend selber wieder, funktioniert dann aber immer noch nicht.


    Momentan behelfe ich mir mit einem Script, das erst den Security-Demon und dann den Service-Layer-Dienst beendet (net stop) und anschließende den SL dreimal hintereinander mit taskkill beendet.

    Danach starte ich beide Dienste wieder (mit net start), danach läuft es meistens wieder. Zwischen den einzelnen Schritten habe ich jeweils 10 Sekunden Pause eingbaut.


    Erfahrungsgemäß funktioniert der SL erst dann, wenn der Dienst mindesten 10 Sekunden wirklich beendet war.


    Ich hatte es bisher auf den 2008R2 Server geschoben und die wirkliche Problemlösung zurückgestellt, da der Server in der nächsten Zeit eh ersetzt werden soll.


    Viele Grüße, Jörg.

    Moin.


    wenn ich mich richtig erinnere, dann betreffen die Windows-Beschränkungen ausschließlich die SMB Dateifreigaben.


    Demnach müsste es ja eigentlich legal sein, wenn der Client ausschließlich über Port 267 mit dem Server kommuniziert.


    Allerdings bin ich mir nicht sicher, wie der Client im lokalen Netz auf den Server zugreift und ob der Port 267 nicht letztlich einfach nur eine Art VPN-Tunnel für SMB ist. Wäre mal interessant zu wissen, wie der Zugriff über den David-Port eigentlich funktioniert.


    Mit POP/IMAP/ActiveSync müsste es jedenfalls legal sein.


    Viele Grüße, Jörg.

    Moin.

    Es geht auf jeden Fall serverseitig per ISDN mit ECT-Connect oder mit angepasstem Dial-Script per assoziierter Wahl.


    Ansonsten kannst Du auf jedem Client den TAPI120 installieren und darüber wählen. So viel ich weiß geht das ohne zusätzliche TAPI Serversoftware bis 6 Teilnehmer.


    Viele Grüße, Jörg.

    Moin,


    habe eigentlich nur ich momentan so seltsame Anfragen? Ein Kunde hat tatsächlich noch ein David 8 im Einsatz und möchte/muss jetzt wegen sSMTP und POPs auf die aktuelle Version updaten.


    Meine Frage: Geht das noch in einem Rutsch, also aktuellen Installer drüber laufen lassen, oder muss ich über eine Zwischenversion gehen?


    Viele Grüße, Jörg.

    Aah, Fehler gefunden.


    Der Ordner Unverteilt muss natürlich auch freigegeben sein. Habe dies nachgeholt und die entsprechenden Benutzer hinzugefügt. Jetzt funktioniert es auch in Outlook.


    Dazu noch eine Frage: Bei einer Freigabe für Remote-Access muss ich ja Benutzername und Kennwort angeben. Ist das nur noch aus Gründen der Abwärtskompatibilität bzw. für POP/IMAP?

    Die Berechtigungen für die Benutzer lege ich ja im darunter liegenden Dialog fest.


    Hängt man verknüpfte Ordner besser unter Verknüpfungen auf, oder kann ich sie auch gefahrlos mit dem Eingangsordner des Benutzers verbinden?


    Viele Grüße, Jörg.

    Moin,

    ich habe das gerade einmal probiert und nachträglich eine Verknüpfung erstellt (Unverteilt als Verknüpfung unter "Verknüpfungen") allerdings sehe ich den verknüpften Ordner nicht.


    Der Ordner Verknüpfungen bleibt leer und hat keine Unterordner. Outlook ist die Version 2016.


    Hilft es auch in diesem Falle, die ActiveSync.db zu löschen?


    Viele Grüße, Jörg

    Moin,


    bei einem Kunden kam es zu einer verschobenen Darstellung in den Tabellen Benutzerverwaltung und POP-Konten.


    Schuld daran war ein Zeilenumbruch, der bei der Übernahme der Datenaus einer Textdatei, bei der ein nicht druckbares Zeichen (wahrscheinlich CR/LF) am Ende der Mailadresse stand.



    Der Fehler konnte behoben werden, indem ich den letzten Buchstaben und alles dahinter mit ENTFgelöscht und neu eingegeben hatte.


    Nur zur Info, falls noch jemand über den Fehler stolpern sollte.


    Viele Grüße, Jörg.

    Hallo,


    kenn mir jemand sagen, ob David 3 mit dem aktuellen Patchstand auf einem Server 2008R2 stabil läuft?


    Ich bin mir darüber im klaren, dass der Server 2008R2 nicht mehr unterstützt wird und habe den Kunden auch entsprechend aufgeklärt, er beharrt aber darauf, den 2008R2 noch bis zum Herbst zu betreiben. Das System ist geschlossen und bis auf den SMTP-Port nicht mit dem Internet verbunden, es werden neben der Fax-Funktionalität nur Mails versendet, nicht empfangen.


    Viele Grüße, Jörg.

    Sooodele,

    der Fehler ist heute wieder aufgetreten. Er tritt dann auf, wenn der Benutzer per IMAP den Ordner "Zugriffsprotokoll" (mit ca. 3000 Einträgen) löscht.


    Im Debug-Log taucht dann folgendes auf:


    5/19-09:19:02,617 (00001020) Got complete TCP Message (Size=13)


    5/19-09:19:02,617 33.292 IDLE

    5/19-09:19:02,633 + idling

    5/19-09:19:03,383 (00000984) read (27/0)

    5/19-09:19:03,383 (00000984) Got complete TCP Message (Size=40)

    5/19-09:19:03,383 RUBY0003 SORT (DATE) US-ASCII NOT SEEN

    5/19-09:19:03,383 RUBY0003 BAD Protocol error: command unknown or arguments invalid

    5/19-09:19:03,383 (00000984) write (67)

    5/19-09:19:03,383 (00000984) read (15/1)


    # Absturz und manueller Neustart

    5/19-09:24:06,645 (DAVIDTLS) Load module certificates...

    5/19-09:24:06,645 (DAVIDTLS) Try to load certificate: Let's Encrypt



    Ich habe den Fehler an Tobit gemedet und testweise die automatische Bereinigung auf 1 Tag gestellt. Mal schauen, ob das hilft, oder ob das Problem auch bei wenigen Einträgen auftaucht.


    Viele Grüße, Jörg.

    Da hast Du schon mehr als ich. Ich habe Outlook mit meinem Account verbunden, ich sehe nur die Ordner und keinerlei Inhalt. Outlook synchronisiert brav, zeigt keine Fehlermedungen, es bleiben aber alle Ordner leer. Mein Android-Handy hingegen synchronisiert mit gleichen Einstellungen einwandfrei.


    Ich werde mir das nächste Woche einmal genauer anschauen, diese Woche ist terminlich zu voll für Jugend-Forscht-Projekte.


    Viele Grüße, Jörg.

    Moin,

    ich habe gerade folgendes Problem:

    Ein Kunde hat eine Mail geschrieben, die auch korrekt im Unverteilt gelandet ist. Ich hatte diese Mail gelesen und auch mit dem Kunden telefoniert.


    Seit 3 Tagen ist die Mail im David Infocenter nicht im Ordner auffindbar. Suche ich mir im Eingangsprotokoll die Message-ID heraus und suche auf Dateiebene nach der ID, dann finde ich die Mail samt Inhalt.



    Falls tatsächlich jemand die Mail versehentlich gelöscht haben sollte, dann müsste sie ja eigentlich nach dem nächtlichen Purge-Job auch auf Dateiebene gelöscht worden sein.


    Hat jemand eine Idee, was hier passiert sein könnte?


    Viele Grüße, Jörg.

    Moin,

    schon einmal besten Dank für eure Rückmeldungen. Macht es denn eventuell Sinn, Gruppen-E-Mail-Ordner (z.B. Unverteilt [ja, ich weiß, Unverteilt ist eigentlich kein Gruppenordner, aber die meisten Kunden sind das so gewöhnt]) separat per IMAP einzubinden?


    Habe ich das richtig verstanden, dass ich verknüpfte Ordner vor der RemoteAccess-Freigabe einstellen muss, das also nachträglich nicht mehr ändern kann? Gilt das auch z.B. für Adressordner?


    Viele Grüße, Jörg.

    Moin,


    eine kurze Rückmeldung. So plötzlich wie das Problem aufgetreten ist, so ist es auch wieder verschwunden. Ohne Neustart, Updates oder Änderungen funktioniert es plötzlich wieder einwandfrei.


    Fehlerprotokolle für abgestürzte David-Dienste findet man übrigens unter:


    C:\ProgramData\Microsoft\Windows\WER


    Viele Grüße,

    Jörg.

    Moin Moin,


    seitens meiner Kunden wird immer wieder die Anforderung an mich herangetragen, Outlook als Mailclient zu verwenden.

    Hintergrund: Die meisten bzw. fast alle Hersteller von Branchensoftware unterstützten ausschießlich Outlook. Die wenigen, die eine David-Integration bieten pflegen diese meist nur stiefmütterlich und mit eingeschränktem Funktionsumfang. Ich würde bei diesen Kunden gerne David als Mailserver behalten und mir die Migration zu Exchange ersparen.


    Daher meine Frage: Wer nutzt Outlook als Client am David-Server produktiv?


    Die prinzipielle Anbindung per Exchange ActiveSync Web habe ich bereits getestet, dies funktioniert aich bei den meisten Postfächern, wobei ich immer wieder Benutzer haben, bei denen die Synchronisation zusammenbricht (Outlook stürtz ab und lässt sich nur durch Löschen des Profils wiederbeleben) und erst nach Anlegen eines neuen Benutzers in David richtig funktioniert.


    Weiterhin stelle ich mir die Frage, wie man Gruppen-Mailordner, Gruppen-Kalender und globale Adressbücher sinnvoll abbilden kann.


    Hat hier jemand einen Tipp oder Erfahrungsberichte für mich?


    Viele Grüße,


    Jörg.