Posts by journeyman

    Hi, danke für den Tip.

    Mittlerweile läuft es. Ich hab vom Hoster ein "include" für SPF bekommen, dass alle IPs abdeckt, die senden dürfen. Auf Reverse DNS warte ich noch, sollte aber auch bald eingetragen sein.

    Des Weiteren habe ich DMarc konfiguriert und auf dem David in der postman.ini EHLOWITHDOMAIN auf true gesetzt sowie die Domain in den Hostnamen eingetragen.

    Letzter Schritt war den Outbound Scan von AVAST zu deaktivieren. Das Teil setzt eine Eintrag im Header, was anscheinend manchem Spamfilter nicht schmeckt.

    Sollte ich dann immer noch Probleme haben, werde ich deine Rat befolgen und "Problemkunden" die Messages direkt schicken.

    Vielleicht kannst du das noch etwas genauer beschreiben.

    eine Delegation für unser /24 einrichten lassen

    Sowie ich das verstehe, wird dann auch der interne IP-Bereich definiert? Ich sehe ja immer die interne IP vom David im Mail Header. Hat das damit etwas zu tun?

    Trotzdem bleibt diese Problem. Alle versendeten Mails landen im Spam-Ordner des Empfängers.

    RDNS_NONE Delivered to internal network by a host with no rDNS

    Ich lasse den ISP folgendes eintragen und hoffe, dass das Problem damit gelöst ist.

    Code
    xxx.xxx.237.109.in-addr.arpa.  1800   IN  PTR   mail.kunden-domain.com

    Hallo, du musst das beim Provider machen der der die das Internet gibt.

    Dort bekommst du eine Feste IP Adresse und die muss auf den Hostnamen zurück auflösen.

    bsp: nslookup mail.deineDomain.de => xx.xxx.66.3

    prt : nslookup xx.xxx.66.3 => mail.deineDomain.de

    sowas bei Telekom gibt idr. p4317df57.ipconnect.de aus das muss korrigiert werden

    Guten Morgen,

    ich will das jetzt gerade nochmal doppelchecken.

    Ich habe einen David Server, der über eine statische Adresse (xx.xxx.66.3 vom ISP Router beim Kunden) mit dem Internet verbunden ist. Der David holt/sendet die Mails vom/zu einem Host (Alfahosting / 109.237.xxx.xxx).

    Mache ich einen nslookup auf den MX Record, in diesem Fall mail.kunden-domain.com, erhalte ich die IP die ich auch erhalten würde, wenn ich das mail. weglassen würde. Diese IP ist allerdings nicht die IP vom Mail Server ist. Denn eben kam eine Mail zurück die besagt, dass 550-109.237.yyy.zzz (andere IP) nicht berechtigt ist mails von kunden-domain.com zu verschicken.

    Welche IP muss ich denn jetzt als Reverse Lookup nutzen?

    Des weiteren stelle ich mir die Frage, ob es bei der Reverse Lookup Angelegenheit nicht zu Konflikten kommt, da sich auf dem Host mehrere Domains eine IP Teilen.

    Den ISP habe ich jetzt auf jeden Fall am Start und der würde auch den Eintrag vornehmen.

    Grüße von der südlichen Halbkugel.

    Wie gesagt mails gehen raus und kommen rein.

    Nur landen einige im Spam-Ordner beim Empfänger wegen

    3.1 RDNS_NONE Delivered to internal network by a host with no rDNS

    und

    2.3 FSL_HELO_BARE_IP_1 No description available.

    Alles läuft über Port 465 (SSL)

    Quote


    SPF so das Alphahosting also alle eingetragenen MX Server zur Domain und vielleicht noch die feste IP vom Anschluss (ISP) sofern der Fest ist.

    Das verstehe ich nicht so ganz. Durch den MX-Eintrag wird ja schon definiert, welcher Mail Server mit welcher Domain verbunden ist, oder?

    Ergo müsste dieser SPF Eintrag ausreichen, das der Tobit vom Provider Mail Server akzeptiert wird. .

    v=spf1 a mx ip4:xx.xxx.66.3 -all

    Dann sollte das ja eigentlich so passen.

    v=spf1 a mx ip4:xx.xxx.66.3 ip4:192.168.0.145 -all

    Also das steht im Header von Mails drin, die ich von Tobit erhalte.

    Received: from [169.254.138.79] (unknown [xx.xxx.66.3])

    by alfa.alfahosting-server.de (Postfix) with ESMTPSA id 6FEF8E980F60

    for <testaccount@.com>; Fri, 7 Jan 2022 09:31:12 +0100 (CET)

    Received: from 192.168.0.145 [169.254.138.79] by 192.168.0.145 with David.fx (0554.49454A444D464D4B4F4C);

    Die APIPA 169.254.138.79 kommt von einem Loopback Adapter. Hab den jetzt disabled.

    Jeder User hat ein eigenes Konto.

    Dementsprechend sind die User auch im Tobit angelegt und jedes Tobit-Konto verbindet sich mit dem eigenen Konto beim Host.

    In den Eigenschaften des Postman SMTP Service ist die Authentifizierungsmethode SMTP (AUTH=LOGIN) ausgewählt und einer der User eingetragen. Anders habe ich die Authentifizierung nicht hinbekommen.

    Und das Problem tritt nur beim Versenden auf.

    OK, jetzt habe ich es verstanden. Kurz vorm Wochenende fällt der Groschen langsamer.

    Was ich mich frage ist, warum ich so einen Punk machen muss, wenn das bei Strato vorher ohne Problem geklappt hat. Auch ohne den Eintrag beim ISP.

    nein, damit setzt Du nur den SPF.
    Du must Dich auf das Kundencenter beim Provider einloggen und dort den Reverslookup einrichten. Ist oft nur ein / zwei klickt.
    Dann sieht die Gegenstelle dass die übermittelte Domäne zu Deiner IP gehört.

    Leider ist das bei Alfahosting nicht so simpel. Man muss manuell den Eintrag vornehmen. Aber jetzt weiß ich wenigsten, woran es hapert. Danke für die Hilfe und ein schönes Wochenende.

    Hallo zusammen,

    ich habe ein Problem mit Reverse DNS. Dementsprechend landen die Mails im Spam Ordner.

    Header der Mail zeigt folgendes:

    3.1 RDNS_NONE Delivered to internal network by a host with no rDNS

    Anscheinend hilft mein DNS Eintrag auf dem Provider Server nicht wirklich.

    v=spf1 a mx ip4:xx.xxx.66.3 ip4:192.168.0.145 ip4:169.254.138.79 -all


    xx.xxx.66.3 ist die statische IP vom Internet Router. (x ist hier ein Platzhalter)

    192.168.0.145 ist die lokale Adresse vom David Server

    169.254.138.79 mit eingebunden, weil diese IP im Email Header erscheint.


    "Received: from 192.168.0.145 [169.254.138.79] by 192.168.0.145 with David.fx (0554.49454A444D464D4B4F4C);"

    Ich könnte da den ein oder anderen Tip gebrauchen.

    Grüße Lutz

    Ich werde das Tool mal ausprobieren. Danke. Allerdings gehe ich davon aus, dass bei der Prüfung nach der Domain gefragt wird und die ist ja bekanntlich noch mit dem alten Server verknüpft.

    Glücklicherweise kann ich DNS-Einträge selber vornehmen. Von daher das hier als txt eingesetzt:

    v=spf1 a mx ip4:IPvomGateway ip4:LokaleIPvomServer -all

    Gebracht hat es nichts.

    Guten Morgen,

    ich kann mittlerweile eMails verschicken. Nachdem ich im SMTP Service bei Provider die Authentifizierungsmethode geändert habe. Habe "Use grabbing server account" in "SMTP (AUTH=LOGIN)" geändert. Das heißt, ich habe einen eMail User, der dem Smarthost bekannt ist, hier eingetragen. Allerdings kommen die Mails beim Empfänger als Spam an.

    LOG:

    0.2 BAYES_00 BODY: Bayes spam probability is 0 to 1%

    [score: 0.0000]

    0.4 MIME_HTML_MOSTLY BODY: Multipart message mostly text/html MIME

    0.0 HTML_MESSAGE BODY: HTML included in message

    3.1 RDNS_NONE Delivered to internal network by a host with no rDNS

    0.0 TVD_SPACE_RATIO No description available.

    2.3 FSL_HELO_BARE_IP_1 No description available.

    0.2 HELO_MISC_IP Looking for more Dynamic IP Relays

    Ich denke, wenn ich Reverse DNS hinbekomme, gehen die Mails ohne Probleme durch.

    Fragt sich nur wie.

    Vielleicht liegt es daran, dass die Domain noch nicht auf den Smarthost transferiert wurde.

    Bisher arbeite ich immer noch mit der Weiterleitung vom alten auf den neuen Server, womit David verbunden ist. (wie ganz oben beschrieben)

    Hi,

    sorry für die späte Rückmeldung. Umstellung ist soweit gelaufen.

    Mails werden auch ordnungsgemäß abgerufen. und in die richtigen Postfächer verteilt.

    Problem ist das senden.

    Habe beim SMTP Service den neuen Provider eingetragen.

    Authentifizierungsmethode war vorher SMTP (AUTH=LOGIN). Das habe ich geändert auf "Use grabbing server account" weil jedes Postfach seine eigene Anmeldung benötigt.

    Versuch mit Port 587:

    Versuch mit 465 (SSL) ergab einen Timeout nach 2 Verbindungsversuchen. Das gleiche bei Port 25.

    Das ganze habe ich auch nochmal mit Hilfe einer Delivery Method versucht. Hat auch nichts gebracht.

    Habt ihr eine Idee?


    P.S. Server ist nicht von Extern erreichbar.

    Gruß

    Lutz