David Service Layer beendet sich alle 2 Minuten

  • Hallo


    Seit heute beendet sich der Service Layer alle 2 Minuten. Q-100.559 aus uralter Zeit habe ich schon durchgeführt.
    Wir haben gestern das Update auf David 3 gekauft und sitecare erneuert. Als Version meldet David 12.00a 3045.
    Was kann man noch tun? Bin zur Zeit beruflich unterwegs und kann nur per Fernzugriff auf den David-Server.

    Vielen Dank
    Holger

  • Hallo nochmal


    Das Update habe ich noch nicht eingespielt. Zuviel Panik dass dann gar nix mehr geht.
    Der Tobit-Support schreibt:

    "Gibt es Fehlermeldungen im Windows Event Log?

    Wenn Sie Testweise das Verzeichnis david\archive\user umbenennen, startet der SL dann?"

    Ist das Umbenennen nach beenden aller Dienste gefahrlos und rückgängig zu machen?
    Sollte der SL dann laufen, deutet das ja auf einen Archivfehler hin. Wie kann man das reparieren?

    Fehlermeldung im Eventlog:


    Name der fehlerhaften Anwendung: sl.exe, Version: 12.0.3045.0, Zeitstempel: 0x5c3c4a14

    Name des fehlerhaften Moduls: sl.exe, Version: 12.0.3045.0, Zeitstempel: 0x5c3c4a14

    Ausnahmecode: 0xc0000409

    Fehleroffset: 0x002a755e

    ID des fehlerhaften Prozesses: 0x2734

    Startzeit der fehlerhaften Anwendung: 0x01d722f1359512c3

    Pfad der fehlerhaften Anwendung: C:\David\Code\sl.exe

    Pfad des fehlerhaften Moduls: C:\David\Code\sl.exe

    Berichtskennung: e25cc072-024f-4075-bb41-ae9383ab2c36

    Vollständiger Name des fehlerhaften Pakets:


    Die Firma steht langsam Kopf, bzw. bald gar nicht mehr wenn das Problem nicht bald geklärt werden kann. Lebt und stirbt mit David.

    Verzweifelter Hilferuf
    Gruß Holger

  • Updates und deren Rückabwicklung sind bei David relativ schmerzfrei, da in der Regel nur die EXEs ausgetauscht werden und eher selten mal wirklich neue Funktionen hinzukommen, die z. B. in den Datenstrukturen etwas verändern. Am Format des Archivsystems an sich wurde, soweit ich es weiß, quasi "seit Ewigkeiten" nichts mehr modifiziert, von daher kannst du das mit dem Umbenennen von \archive\user durchaus mal ausprobieren. Kaputt gehen wird dabei nichts.


    Update bitte unbedingt machen, die Gefahr, dass sich dabei etwas zerschießt, ist gering - sollte es doch passieren, das gleiche Rollout einfach noch einmal drüberspielen oder über den Ordner Z$BACKUP den alten Stand wiederherstellen. Wie gesagt, da werden letztlich nur ein paar EXEs ausgetauscht.


    Und auch hier der Hinweis: Wenn ihr euch wirklich nicht traut und ein Unternehmen "dran hängt": https://tobit.software/kontakt -> "Vertriebspartner bundesweit". Oder hier im Forum jemanden beauftragen. Oder mir eine PM schicken. ;-)


    EDIT: Fällt mir gerade noch ein, vor der Aktion mit dem Umbenennen des Archives würde ich empfehlen, Grabbing Server und Postman zu beenden - sonst kommen evtl. neue Nachrichten rein, und David weiß nicht, wohin damit. Es geht ja erstmal nur darum, herauszufinden, ob der SL ohne User-Archive stabil gestartet bleibt.

    Sollte es wirklich daran liegen, folgt vermutlich eine Fleißarbeit: Alle Archive durchschauen, ob irgendwo etwas inkonsistent ist. Reparieren lässt sich das mit manuellem Umkopieren oder ARCUTIL, aber es wird fummelig werden.

  • nordtech

    Danke für die Info.
    Ich hatte alle David-Dienste beendet.
    Leider kann ich das Userverzeichnis nicht umbenennen (angeblicher Schreibschutz). Ein Unterverzeichnis eines Users blockiert, komischerweise kann ich innerhalb dieses Verzeichnisses alle Ordner und Dateien umbenennen.
    Somit hänge ich erstmal fest.

    Holger

  • Update
    Umbenennen erfolgreich nach 2. Neustart.
    Der Servicelayer hat sich wieder beendet. Alle anderen Dienste waren aus.
    Also Update? Nur versucht David das Update seit vorgestern runterzuladen und wird nicht fertig.
    "david-rollout-331.exe.part1" und "david-rollout-331.exe" in verschiedenen Größen.

    Holger

  • Hallo
    Ich hatte den Download aus dem DavidAdmin gestartet, da aber der Servicelayer immer wieder abstürzte, fing der Download immer wieder von vorn an. Ich habe dann das Rollout direkt heruntergeladen. Da das Problem nicht am Archiv lag und im Eventlog nichts erkennbar war, habe ich das Rollout manuell gestartet. Danach lief der ServiceLayer wieder dauerhaft ohne Absturz. :):thumbup:

    Nochmals Danke
    Holger

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!