Go Integrator auf Terminal Server installieren für David FX (TAPI)

  • Kann mir damit ggf jemand behilflich sein und/oder sagen wie ich es schaffe.


    Es geht um dieses Produkt:


    Das habe ich hier heruntergeladen und würde das gerne auf meinem Server installieren.


    Ich hab es als Admin installiert, soweit so gut.
    Dann starte ich es und richte es ein, es klappt auch alles.
    Nun möchte ich den 2. Benutzer nutzen, logge mich ein und möchte es dort auch starten. Software istja installiert.
    Aber maximal ne Sekunde bleibe die connect.exe offen und verschwindet wieder.


    Dann wollte ich die Software nochmal installieren auf diesem Account, aber dann sagt er mir entweder reparieren oder eben deinstallieren.


    Es lässt mich also explizit nicht gleichzeitig das installierte Programm ausführen, obwohl es gnaz klar Terminal Server unterstützt:


    Ich kann es auch nicht pro Benutzerkonto installieren, da man nur reparieren oder deinstallieren kann.


    Der Support hilft mir aktuell auch nicht weiter und verweist auf das Manual.


    Selbst mit dem Tipp den ich hier finde:
    https://gointegrator.com/help/…=1143&lang=uk&version=3.0


    Bringt mir das nicht viel...


    Mit diesem manuel hab ich dann geguckt auch nichts gefunden
    https://lindentech.com.au/wp-c…_User-Guide_R2.6_v1.1.pdf



    SObald ich die Anwendung auf bspw Benutzer 1 schließe, Benutzer 2 mich anmelden am Terminal Server per RDS, dann starte klappt es auch.
    Nur eben nicht gleichzeitig.


    Kennt sich wer damit aus?!


    Wenn es nur einmal gestartet sit klappt alles wunderbar, auch mit TAPI von DAvid FX eingerichtet. Klappt supi...
    aber eben nur eine Instanz von connect.exe möglich,


    Habe dazu auch mal ein Video gemacht:



    Installiert ist das Programm unter: C:\Program Files (x86)\Go Integrator
    Und die jeweiligen Einstellungen sind hier:
    C:\Users\Florian\AppData\Roaming\GoIntegrator


    also ich weiß nicht weiter...

  • So kleines Update:


    Ich habe die Version 2.6 auf dem Server installiert und da klappt es das 2 x die connect.exe laufen.


    Mal schauen ob der Support dafür noch eine Lösung finden wird, denn für Version 2.6 habe ich keine Lizenz, und Telekom verkauft nur für die 3.0, sprich meine ist nicht gültig...
    Aber irgendwo muss sich in der Installationsroutine ja was geändert haben, sonst würde die 3.0er ja auch wie die 2.6er funktionieren.

  • Guten morgen,


    ich habe nun noch eine Rückmeldung erhalten vom Hersteller:



    Zitat
    Yes version 3.0 works with .net version 4.5.2 that does not work on windows 2008. We are going to remove this from the goIntegrator.com website
    [/quote]Diese Antwort macht aber eigentlich wenig Sinn, denn auf meinem Windows Server 2008 R2 ist aktuell 4.7 installiert.


    Das dürfte ja dann keine Kompatibilitätsprobleme geben..


    Die Version 2.6 (vorgängerversion) da funktioniert es aktuell einwandfrei, dass diese auf derm TS installiert wird und von allen Benutzern genutzt werden kann. (Mehrfachausführung der connect.exe)

  • Ok weiteres Update...



    Sprich dass Go Integrator 3.0 definitv nicht auf Windows Server 2008 R2 funktionieren sollte, jedenfalls nicht als Server Installation.
    Ich kann es öffnen auf dem Serverund es funktioniert auch, nur die gleichzeitige Ausführung der connect.exe klappt nicht.


    Kennt sich jemand mit Servern aus und weiß wie ich das ggf "tweaken" kann damit es dennoch funktioniert? Vielleicht so dass die software glaubt sie sei auf Windows Server 2012 bspw?