Servicelayer beendet sich immer wieder

  • Moin,


    ich habe seid heute Morgen ein ernsthaftes Problem.
    Mein Servicelayer beendet sich immer wieder.
    Auch das manuelle neustarten des Dienstes bringt nichts.
    Es wurde kein Update oder ähnliches Installiert. Gestern Abend funktionierte noch alles einwandfrei.
    Ich habe dann heute Morgen die Datensicherung von gestern zurückgespielt. Auch das hat keinen Erfolg gebracht.
    Hat einer von Euch eine Idee?


    Gruß
    Boetker

  • versuche den Standard:


    Löschen aller TEMP Dateien in Tobit nach KB

    09-f9-11-02-9d-74-e3-5b
    MfG Kingcopy seit C16 / C64
    Fachinformatiker / Systemintegration
    IT-Systemadministrator
    David (R) 2017 / 20 User / 100 GB
    David (R) 2017 / 150 User / 900 GB
    David FX 2011 / 5 User / 15 GB
    d8-41-56-c5-63-56-88-c0
    [/size]

  • Hallo kingcopy,


    habe nach dem Artikel Q-100.232 alle Tempdateien gelöscht.
    Danach den Servicelayer neu gestartet....kein Erfolg.
    Server neu gestartet....kein Erfolg.
    Freier Plattenspeicher 48 GB.
    Virenscanner von Tobit deaktiviert...bringt auch nichts.


    Hat noch einer ne Idee????

  • Knowledge Base schon durch? Z.B.:


    Q-101.239 Auslastung der SL.EXE bei 100 %
    Q-101.676 DvISE Service Layer lastet die CPU zu 100% aus
    Q-101.830 Mögliche Ursachen beim Absturzes des David Service Layers

  • Erstellen einer Debug-Datei des David Service Layers Q-106.249


    Um beim Betrieb von David unter Windows eine Debug-Datei des David Service Layers zu erstellen, führen Sie folgende Schritte durch:

    • Beenden Sie den Dienst »David Service Layer«
    • Wechseln Sie im Windows Explorer in das Verzeichnis »DAVID\CODE«
    • Benennen Sie die dort die »SL.EXE« in »SL.EX_« und die »SL-DB.EXE« in »SL.EXE« um

    Durch das umbenennen der »SL-DB.EXE« in »SL.EXE« wird beim Neustart des David Service Layer der Debug Service Layer gestartet. Starten Sie den Service Layer über die Eingabeaufforderung (über »Start -> Ausführen« mit dem Befehl »CMD.EXE) mit dem Parameter -console (z.B. »C:\David\Code\SL.EXE -CONSOLE).
    Um die jetzt auslesbaren Aktivitäten des David Service Layers in eine Datei zu schreiben, gehen Sie wie folgt vor:

    • Rufen Sie über »Start -> Ausführen«, mit dem Befehl »CMD.EXE«, die Eingabeaufforderung auf
    • Wechseln Sie mit dem Kommando »CD DAVID\UTIL\WINDOWS« in das Verzeichnis, in der die Datei »DBMON.EXE« abgelegt ist
    • Rufen Sie diese mit dem folgenden Parameter aufDBMON.EXE > C:\sldebug.txt
    • Im Anschluss starten Sie den Dienst »David Service Layer« neu.

    Daraufhin finden Sie unterhalb von »C:\« die Textdatei »SLDEBUG.TXT«.
    Die Aktivitäten des David Service Layers werden nun in dieser Textdatei fortgeschrieben.
    Wichtig: Sie sollten dieses Verfahren nur zur Problemanalyse nutzen, da bei einer stetigen Verwendung des Debugmodus große Datenmengen anfallen.
    Damit nach dem Protokollieren der Aktivitäten des David Service Layers wieder der eigentliche David Service Layer verwendet wird, müssen Sie lediglich die umbenannten Dateien wieder mit den Ursprungsnamen versehen. Im Anschluss muss der Dienst »David Service Layer« neu gestartet werden.

  • wow Super,
    das ist ja wieder heiss und sehr informativ.
    das die SL derart abschmiert ist sehr selten,


    was genau ist an der archiv Datei defekt?
    wie kommt soein defekt zustande...
    Gibt es generell einen Dateisystemfehler?
    das sollte man noch genauer untersuchen.

    09-f9-11-02-9d-74-e3-5b
    MfG Kingcopy seit C16 / C64
    Fachinformatiker / Systemintegration
    IT-Systemadministrator
    David (R) 2017 / 20 User / 100 GB
    David (R) 2017 / 150 User / 900 GB
    David FX 2011 / 5 User / 15 GB
    d8-41-56-c5-63-56-88-c0
    [/size]

  • Moin,


    habe das Problem nicht alleine lösen können. Wäre auch ehrlich nicht darauf gekommen, das eine beschissene
    Achrive.dir das ganze System lahm legt.
    Zum Schluß war sogar ein Mitarbeiter von Tobit mit auf unserem System.
    Haben dann Stück für Stück Dateien und Ordner ausgeklammert, bis wir letztendlich
    das defekte Archive gefunden haben. Was an dem Archiv defekt war kann ich leider nicht genau sagen.
    Aber nach Arcutil war alles wieder okay.
    Was ich nur sehr schwach finde ist, dass es keinen Report gibt an welcher Stelle der SL abkackt.
    Das wäre doch sehr hilfreich gewesen.


    Danke nochmal für Eure Hilfe


    boetker