Tobit und Sophos SPX Mail (Tipp für Nutzer)

  • Hallo,
    leider habe ich keine Rubrik gefunden für die Möglichkeit von Tips und Tricks für Tobit selbst.
    Drum schreib ich das mal hier rein.


    Sollte jemand versuchen Tobit in zusammenarbeit mit Sophos nutzen und die SPX ( Secure PDF Exchange) Funktion nutzen wollen, wird ihm schnell auffallen das das so gar nicht geht.
    Für Outlook gibt es ein Plugin was man installieren kann.
    Für Tobit nicht .. Abhilfe schaft aber an kleines Script, welches ich hier mit angeben möchte...


    "Wichtig: Die Mail muss über den SMTP Proxy der Sophos verschickt werden, und die Sophos muss mit dem SPX konfiguriert sein."


    Das folgende Script hinterlegen unter sowie die Angehängte Datei Sophos-SPX-Encrypt.zip entpacken und die Icon Datei dort ablegen. (die kann aber auch gewechselt werden wenn gewünscht):


    LAUFWERK_VON_TOBIT_INSTALL:\David\Code\scripts



    Dann nur noch dem Benutzer das Script zu ordnen...(im David Admin)

    und


    Nun sollte beim Client das ganze wie folgt aussehen.

    Der Header wird der E-Mail hinzugefügt, wenn der "Button" gedrückt wird somit ist dieser dann aktiv.


    Vielleicht kann es ja jemand nutzen.
    Bei Fragen hierzu einfach melden.

    Tobit FX12 auf W2016 an VMWare ESXI6.5 Essentials,
    ActiveSync über Sophos SG210 /Reverse Proxy(WAF) - SMTP Proxy TLS

    Dieser Beitrag wurde bereits 2 Mal editiert, zuletzt von BlackShadow () aus folgendem Grund: Titel geändert - da es ja ein Tipp ist und kein Problem :)

  • Hallo, das Script ist ja oben angegeben.

    die beiden Screenshots waren glaube ich nur das Zuordnen von den Scripten zum User.

    Ich schau kurz


    hier mal das ICON als ZIP


    Dann David Admin => User Öffnen => Benutzerdaten => David Client konfigurieren => Scripte =>

    Hacken setzen bei Individuelle Scripts und Hinzufügen (script auswählen) welches zuvor abgelegt worden ist.

    Dateien

    Tobit FX12 auf W2016 an VMWare ESXI6.5 Essentials,
    ActiveSync über Sophos SG210 /Reverse Proxy(WAF) - SMTP Proxy TLS

    Dieser Beitrag wurde bereits 1 Mal editiert, zuletzt von BlackShadow ()

  • Hallo BlackShadow,

    dank deines Scripts und der Anhänge konnte ich SPX erfolgreich einrichten und testen.


    Leider funktioniert es aktuell aber nicht mehr.

    Ich denke, dass der David Client seit dem letzten Update den SPX-Header Eintrag rausfiltert und dadurch verschlüsselt dann die Sophos nicht mehr.

    In den Mail-Headern hat der SPX-Eintrag auf jeden Fall gefehlt und das schon

    Dummerweise merkt man davon dann auch nichts und die Mail wird samt Anhang einfach unverschlüsselt verschickt.

    Funktioniert es denn bei dir noch?

  • Hallo,

    signiert Tobit oder Sophos noch?

    Änderungen an der Sophos gemacht ?

    da ich SMIME mach an der und über die Sophos musste ich noch nen hacken neu setzen für "SPX Verschl. bevorzugen"

    Tobit FX12 auf W2016 an VMWare ESXI6.5 Essentials,
    ActiveSync über Sophos SG210 /Reverse Proxy(WAF) - SMTP Proxy TLS

  • Hallo BlackShadow,


    ich bin gerade auf das Script gestoßen und habe es gleich mal getestet bei mir aber leider funktioniert es nicht.

    Der Schalter erscheint bei mir im Editor aber zeigt keine Wirkung.

    Die Mails kommen immer unverschlüsselt an.

    Funktioniert es aktuell bei Dir noch?

    SPX an sich funktioniert, wenn ich es generell in der XG aktiviere- unter Email>Richtlinien und dann in der Richtlinie eine Vorlage auswähle.


    Gruß Zille

  • Hallo Zille,

    ja mit der SG klappt das immer noch.

    Wenn die Mail beim Empfänger ankommt, ist dann der Header noch auf das Flag gesetzt?


    X-Sophos-SPX-Encrypt: 1


    Wie sind den die restlichen Einstellungen.

    SPX Vorlage ( vom Empfänger festgelegtes Kennwort ) ?

    Tobit FX12 auf W2016 an VMWare ESXI6.5 Essentials,
    ActiveSync über Sophos SG210 /Reverse Proxy(WAF) - SMTP Proxy TLS