David zehn Server tot nach Windows Neustart mit letzter als funktionierend bekannte Konfiguration

  • Hi,


    folgendes Problem: ich habe david zehn auf einem Windows Server 2016 Essentals am laufen.


    Lief soweit auch jetzt gut eine Woche ohne Probleme. Jetzt musste ich aber beim Windows Neustart aufgrund eines anderen Problems chkdsk ausführen, wodurch Windows in eine Endlosschleife gelangt ist und die einzige Abhilfe "Windows mit letzter als funktionierend bekannter Konfiguration starten" war.


    Seither funktioniert Windows und alles weitere drumrum - aber David nicht mehr. Der Server ist komplett offline, im David Administrator wird unten "Servername - Offline" angezeigt.


    Wenn ich das David Dienste Fenster öffne, ist die Liste komplett leer. Also ich könnte von dort aus nicht mal was starten.



    Jemand eine Idee was da los ist?

  • Update:


    Wenn ich David neu installiere, und dann nur das Archive Verzeichnis kopiere, sind die Mails wieder alle im Unterordner des jeweiligen Users da.


    Wenn ich hingegen den Ordner der Neuinstallation komplett lösche, und dann das alte David Verzeichnis reinkopiere, will der Service Layer nicht starten.



    Des Lösungs Problem ist also ersteres. Nur sind natürlich die Ordner nicht mehr den entsprechenden Usern zugeordnet, Postman nicht konfiguriert usw.


    Deshalb frage an euch: Was aus dem alten David Verzeichnis muss ich noch mit umziehen, dass die Daten wieder da sind? bzw. was muss ich tun, um die jeweiligen User Archive wieder den neuen Usern zuzuordnen (hier muss mehr gemacht werden als die SSID anzupassen, da die User in David ja quasi komplett neu angelegt sind)

  • 1) Die völlig veraltete Spam-Engine von David 10 ist nicht mehr ausreichend in der Lage, Spams auszufiltern. Das gleiche gilt für die integrierte alte Doorkeeper-Funktion in Bezug auf Trojaner.


    2) Die aktuellen Patches für Windows 10 und Windows Server 2016 sind mit den alten David dlls nicht kompatibel. Es mag zwar gelingen, diese Dateien bei einer wiederholten Installation von David zu überschreiben. Sie müssen aber damit rechnen dass sich ähnliche Fehler in Kürze wiederholen.

    3) Der Grabbing Server von David 10 kann kein SSL. Es ist damit nicht möglich, SSL-verschlüsselte eMails (Beispiel: 1und1, T-Online u.a.) zu empfangen. Der Workaround über den Postman führt dazu, dass die Regeln nicht funktionieren.

    4) Die SQL-Suche existiert in David 10 nicht.

    5) Die Anbindung von Smartphones mit aktuellem IOS oder Android an einen David zehn Server wird wahrscheinlich nur unverschlüsselt funktionieren. Diese Betriebsart ist aber ab Geltung der DSGVO (Mai 2018) nicht mehr zulässig.

    6) Clients mit ausreichend gepatchtem Windows 10 funktionieren mit David 10 nicht mehr.

    Fazit: Es mag zwar im Laborbetrieb (!) interessant sein, eine Kombination von Windows Server 2016 und David 10 zu erproben. Aber für den Produktivbetrieb taugt sie nicht.


  • Weise die IDs einfach den richtigen Nutzern wieder zu (im DVAdmin) Postman und Grabbingserver kriegst du schon wieder hin.

    Arno

    Bekommst du Provision von Tobit? :-)


    Ja aber wie mach ich das :D


    Ich hab ja die alten Nutzer nicht mehr. Wenn ich jetzt einen Benutzer neu erstelle, hat der z.B. die David ID 10004010.

    Der "alte" Nutzer hatte aber die ID 10004030 und liegt auch unter dem Namen im Archiv. Ich müsste also irgendwie die David ID ändern können, also David "neu beibringen", welchem Nutzer welcher Ordner gehört.


    Das mit der Windows SSID funktioniert ohne Probleme, nur leider greift David noch nicht auf die richtigen Ordner zu




    Fazit: Es mag zwar im Laborbetrieb (!) interessant sein, eine Kombination von Windows Server 2016 und David 10 zu erproben. Aber für den Produktivbetrieb taugt sie nicht.



    Klar du hast Recht. Aber es ist hier ein kleines Labor, und es geht einfach ein Stück weit auch ums Ego, das David besiegt zu bringen :) Zumal gerade das Problem mit den Ordnern zuweisen nichts mit der OS Version zu tun hat, sondern auch früher schon irgendwie funktioniert haben muss... und das will ich mit eurer Hilfe schaffen



    EDIT LÖSUNG:


    Also habs wieder zum Laufen gebracht. Mal kurz den Lösungsweg falls nochmal jemand das Problem haben sollte:


    Mein User Archiv hatte die ID 10004030


    David ändert wenn man neue User anlegt immer die fünfte Ziffer in der User ID. Sprich erster angelegter User: 10004000 zweiter angelegter User: 10008000 usw...


    Wenn man jetzt die User löscht und sich anschließend mit dem Domänenuser Infocenter wieder öffnet, legt David den User neu an, ändert jetzt aber (falls David eben dieser Domänennutzer bekannt ist) jeweils die zweite Ziffer.


    Sprich nach dem ersten mal löschen den Nutzers sah die ID dann so aus: 10004010, nach dem zweiten mal so: 10004020 usw...

    Beim dritten mal hat dann mein Archive wieder gepasst :)


    Ganz getan ists aber noch nicht. Man muss nun noch mit dem Admin das jeweilige Archiv freigeben. Dafür geht man in David unter Archive -> Benutzer -> "Benutzername" und geht per Rechtsklick in die erweiterten Eigenschaft. Dort im (ich meine) dritten Reiter den Ordner für das gewünschte Domänenmitglied freigeben (per Windows Freigabe)



    An die alten Hasen hier: Mir macht das ganz schön Spaß, mit dem David zu arbeiten. Gibts da eine günstige Möglichkeit, das zehner upzugraden? FX für 600€+ ist mir zu teuer. Aber brauch im Prinzip nur zwei User. Geht das auch mit der Start Version?

  • Eine aktuelle Lizenz der Basis Edition sollte ausreichen.
    Sie ist allerdings begrenzt auf maximal 2 User.
    Und es gibt keine Replikation mit anderen David-Servern sowie keine TLDs für Fax oder Anrufbeantworter.
    (Der Replikationsdienst ist in der Basic Edition permanent deaktiviert).

    Exchange active sync mit Smartphones und Webbox funktionieren.