Grabbing Server "unknown user name or bad password" nach einer Stunde

  • Hallo zusammen,


    ich muss für einen Monat für einen Kollegen übernehmen und an Tag zwei natürlich direkt der Supergau..

    Ich bin mit dem System gar nicht vertraut, da es etliche Jahre bevor ich hier angefangen habe installiert wurde und eigentlich schon länger abgeschafft werden soll.


    Das Problem:

    Unser Grabbing Server funktioniert nicht mehr richtig. Zuerst hatte die POP3-Postfachanmeldung über outlook.office365.com gar keine Wirkung. Heute habe ich heute Rollout 414 installiert und alle POP3-Postfächer neu angemeldet, dann ging es wieder. Nach ziemlich genau einer Stunde kriege ich unter Ereignisse jedoch für jede POP3-Abfrage die gleiche Meldung "unknown user name or bad password". Nun habe ich wieder alle Benutzer neu angemeldet und eine Stunde später wieder das selbe.

    Ohne den Tobit geht bei uns leider gar nichts, aber ich kann mich jetzt nicht jede Stunde für 30min hinsetzen und alle Nutzer neu anmelden.


    Ich habe mich über OAuth2 eingelesen und habe den Verdacht, dass kein refresh token generiert oder erstellt wird. Da dieser wohl länger gültig ist als der access token und mit Hilfe dessen der access token wieder erneuert wird, wenn ich das richtig verstanden habe.



    Was ich sonst noch versucht habe:

    • Grabbing Server Dienst neu gestartet
    • David Dienste neu gestartet
    • Den physischen Server neu gestartet

    Ich hoffe jemand kann mir weiterhelfen. Ich bin unendlich dankbar für jeglich Hilfe oder Tipps..

    Edited once, last by Tobias ().

  • da es etliche Jahre bevor ich hier angefangen habe installiert wurde

    Dann hattest Du ja genug Zeit dich damit zu beschäftigen ;)


    Nach ziemlich genau einer Stunde

    Hört sich an wie Gruppenrichtlinien ober sonstige Restriktionen die über einen Server kommen.


    Nun habe ich wieder alle Benutzer neu angemeldet und eine Stunde später wieder das selbe.

    Was bedeutet neu angemeldet? Wo liegen denn die Postfächer bzw. die eMail Domain bei MS?


    Gruss Frank

  • Quote

    Dann hattest Du ja genug Zeit dich damit zu beschäftigen ;)

    Als ich hier angefangen habe wurde gesagt "David kommt bald weg" und ich arbeite deshalb auch gar nicht mit David sondern schon im neuen System. Das ist nun zwei Jahre her, David ist immer noch hier und ich bin der einzige der nicht damit arbeitet. :S

    Quote

    Hört sich an wie Gruppenrichtlinien ober sonstige Restriktionen die über einen Server kommen.

    Es wurden keine Einstellungen am MS-Exchange-Server verändert in den letzten Tagen.


    Quote


    Was bedeutet neu angemeldet? Wo liegen denn die Postfächer bzw. die eMail Domain bei MS?

    Ich habe jeden Nutzer unter "Grabbing Server - POP3-Dienst -> POP3 Postfächer" im David.Administrator aufgerufen und in den Eigenschaften auf "Anmelden" gedrückt, dann E-Mail und Passwort eingegeben.
    Der eigentliche Mailserver von welchem die Mails abgefragt werden liegt bei Microsoft.


    Hier wurde nichts verändert, an keiner Einstellung, in keinem System, da der eigentliche verantwortliche wie erwähnt ausgefallen ist. Es funktionierte von heute auf morgen einfach nicht mehr.

  • Hallo,


    ohne direkt eine Lösung anbieten zu können vermute ich das jetzt irgendwelche Restriktionen bezüglich der Authentifizierung auf MS Seite aktiv sind.

    Das Problem mit MS haben wir nahezu bei allen Kunden entweder 2FA oder MFA oder SMTP Auth der Drucker, irgendwas geht immer nicht.


    Ich kenne mich besser mit David als MS aus.... Kann also nur bedingt helfen.


    LG Frank

  • Das Problem mit MS haben wir nahezu bei allen Kunden entweder 2FA oder MFA oder SMTP Auth der Drucker, irgendwas geht immer nicht.

    Wir nutzen NOCH kein 2FA oder MFA. SMTP ist der lokale David Server. Trotzdem bedanke ich mich für die fixe Antwort.

  • Auch wenn ich mich mit hosted MS Exchange (MS365) nicht gut auskenne habt Ihr gemäß dem Logschnipsel definitiv ein Problem mit den Sicherheitseinstellungen auf Microsoft Seite.
    Die OAuth Token verlieren offensichtlich nach einer Stunde ihre Gültigkeit.

    Das kann verschiedene Ursachen haben, alle davon sind auf Seiten der Microsoft Umgebung zu beheben.

    Einzige Ausnahme davon wäre ein vielleicht zu kurzes Intervall in welchem Euer Grabbing Server auf dem MS Server nach neuen Nachrichten sucht.

  • Einen wunderschönen guten Morgen!

    Nachdem gestern in einer Krisensitzung beschlossen wurde, alle POP3-Anfragen manuell zweimal täglich neu anzumelden, habe ich das heute Morgen als erstes erledigt. Kurz darauf bemerkte ich im Ereignisprotokoll die Meldung "David Hotfix #359302 installed" gefolgt vom Neustart einiger Dienste, unter anderem der Grabbing Server. Bisher halten die Anmeldungen, die gestern noch vor etwa 30 Minuten ungültig gewesen wären.


    Ob es jetzt das Hotfix war oder ob bei MS still und heimlich was verändert wurde weiß ich nicht. Ich werde das ganze jetzt aber nicht an die große Glocke hängen um hier etwas Druck aus zu üben. Ich hoffe der Vorfall löst endlich den Startschuss zur Umstellung auf das neue System aus.


    Allen Beteiligten möchte ich nochmals für die Unterstützung danken. Frohe Weihnachten, schöne Ferien und einen guten Rutsch ins neue Jahr!

  • sieht in der Tat so aus als hätte Tobit heute Nacht den Grabbing Server an eine Änderung bei Microsoft angepasst. Der Hotfix tauscht den Grabbing Server gegen eine Version vom 13.12.2023 aus. Der Hotfix selbst wurde gestern im Laufe des Tages bereitgestellt und bei den meisten dann heute Nacht im Rahmen der nächtlichen Bereinigung heruntergeladen.

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!