Rollout 296 / Anbindung iPhone / TLS

  • Vielleicht kann mir jemand helfen. Nach dem Rollout 296 funktioniert Active Sync/Exchange mail beim iPhone und Android nicht mehr. Nach dem Zurücksetzen auf 295 geht alles wieder.

    Anbindung an Webbox über 8010. Eigenes erstelltes Zertifikat in der Webbox/Code abgelegt. Firewall /Router alles sauber.

    Nach dem Update auf 296 gibt es die neue Funktion TLS Zertifikate verwalten. Dort steht das mein eigenes Zertifikat ist seit 8 Tagen abgelaufen . (Hatte ich garnicht gemerkt und die Handys haben auch nicht gemeckert) Webbox Monitor sagt jetzt SSL failed. Okay ich erstelle ein gültiges neues Zertifikat, und starte die Dienste neu. Das Zertifiakt wird korrekt mit Gültigkeit angezeigt. Der Webbox Monitor bestätigt es geladen zu haben. Das Handy nimmt erfolglos Verbindung auf. (SSL connection failed) Das neue Zertifikat wurde nicht vom Handy geladen. Wie kommt das Handy an das neue Zertifikat? War es nicht so das bei neuen Zertifikaten dem Handy eine Meldung zukommt die man mit okay bestätigt und dann dieses Zertifikat lokal auf dem Handy ist? Liegt das Problem an der Anbindung über Port 8010?

  • Schon mal das Konto neu eingerichtet am iPhone? Dann müsste ja die Warnung durch provoziert werden.


    In solchen Fällen bin ich meistens erfolgreich auf ein öffentliches zertifikat (GeoTrust, SwissSign oder kostenlos per Let's Encrypt) umgestiegen da gerade Apple-Geräte selbst-signierte Zerts nicht mögen.


    Achja, steht Port 8010 in der webbox.ini (unter \Apps\Webbox\Code) als HttpsPort = 8010 oder nur in der Webbox-Konfig. im David-Admin? Falls nein füg das mal hinzu.

  • Hi Timo

    Danke für die schnelle Antwort. Ja der Port ist so in der ini hinterlegt. Hat ja auch seit Jahren alles so funktioniert. Neues Anbinden kann ja nicht die Lösung für sämtliche Handys sein. Das neue Rollout hat definitiv in der TLS Anbindung irgend etwas geändert. Und wenn man die über Tobit bereitgestellten Zertifikate verwenden würde geht das nur über Port 80. Stellt sich also die Frage ob Port 80 für die Anbindung jetzt ein "Muss" ist.