Nach Servermigration funktioniert Volltextsuche nicht mehr

  • Hallo David Gemeinde,


    Wir haben kürzlich erfolgreich einen Kunden mit vielen Postfächern mit Hilfe des Tobit David Migration Tools auf einen neuen Server umgezogen. Nach dem Umzug mussten lediglich einige Kleinigkeiten im Client noch angepasst werden, wie z.B. der Notifier. Aber sonst muss ich sagen: Topp gelaufen!


    Bis auf eine Kleinigkeit: Seit dem Umzug funktioniert die SQL basierte Volltextsuche nicht mehr. Hat jemand eine Idee, wie ich die wieder ans Laufen bringen kann?


    Vielen Dank für eure Hinweise!


    Gruß, Oliver

  • Ich glaube der Sache auf die Spur zu kommen.

    Bei der Grundeinrichtung hat Tobit auf dem neuen Server schon eine entsprechende DB angelegt und der Dienst läuft auch. Siehe Bild2.jpg im Anhang.


    Aber wenn ich die David Dienste neu starte bekomme ich im Eingang des Admins eine Fehlermeldung. siehe Bild1.jpg. Was daran auffällig ist: Der bezieht sich auf eine DB mit Namen SERVER\DAVID1, wenn ich das richtig interpretiere. Aber die eigentliche neue DB nennt sich MAILSRV\DAVID. Liege ich mit meiner Vermutung richtig, dass er versucht auf die falsche DB zuzugreifen? Und wenn ja, wo könnte ich DAVID1 auf DAVID abändern? Und wo den neuen Servernamen angeben?


    Gruß, Oliver

  • Besser mal das SQL Management Studio Installieren, sich mit dem SQL Server verbinden. Und prüfen ob die Datenbanken

    erstellt wurden. Dann den Connect String anpassen, und die Logs im David prüfen.

  • Treffer! Nun tut auch die Indexierung wieder. (siehe Anhang) Also Hinweis an alle, die so eine Migration planen: Schaut euch nachher die INI an. Dort steht noch der alte Server und der alte DB Name drin!


    Vielen Dank für eure Hinweise!


    Oliver

  • Treffer! Nun tut auch die Indexierung wieder. (siehe Anhang) Also Hinweis an alle, die so eine Migration planen: Schaut euch nachher die INI an. Dort steht noch der alte Server und der alte DB Name drin!


    Vielen Dank für eure Hinweise!


    Oliver

    Perfekt. Sowas muss ich mir mal abspeichern. Falls wir mal auf so ein Problem treffen, dann findet man es meist nicht mehr.


    Danke für die o.g . Informationen.


    VG

  • Diese Einträge in der david.ini existieren m.W. aber nur wenn man die manuell dort eingetragen hat bzw. bei einer Installation wenn David eine zuvor schon vorhandene SQL Instanz benutzen soll und dieses beim Setup ausgewählt wurde.

  • Bei dieser Installation war das aber bereits vorhanden. Und wenn nicht, könnte es dort ja ergänzt werden in der Form, wie ich es oben im Screenshot gepostet hatte.

    Das war der Zustand nach einer Migration, richtig? Dabei wird die David.ini vom ursprünglichen Server kopiert. Wenn du die Einträge auskommentierst, müsste es eigentlich auch gehen.

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!