DAVID neu installiert und nichts geht mehr - erbitte Hilfe!

  • Moin ihr Lieben!


    Ich habe einen Windows Server 2019 Datacenter ( GUI ) und diesen jetzt neu aufgesetzt.

    Die Netzwerkeinstellungen sind auf 'Öffentliches Netzwerk', aber feste, interne IP vergeben.

    DAVID ist soweit korrekt installiert ( Admin sieht alles, User sehen nur ihren Ordner ).

    Auf der FRITZ!Box 7590 ist TCP Port 267 und 443, sowie 8443 auf den Server weitergeleitet.

    An der Windows-Firewall habe ich nichts geändert.


    Nun ist das Problem, dass ich zwar im selben Netzwerk am Desktop-PC den Clienten starten und benutzen kann, aber das Synchronisieren mit dem iPhone klappt vorne und hinten nicht.

    SSL-Zertifikat ( WBCERT.pem ) ist mit TLCERT erstellt und im Ordner 'david -> Apps -> Webbox -> Code' abgelegt worden.

    Selbiges für das WebAPI-Zertifikat ( restapi_public.pem ), welches im Ordner 'david -> Code -> Cert -> ssl' liegt.

    Beide Zertifikate sind im David-Admin hinterlegt, mit der DynDNS-Adresse, die auch in der Fritz!Box registriert ist.

    Ebenfalls ist die DynDNS-Adresse auch in der Webbox korrekt hinterlegt und auch unter System -> Konfigurieren.


    Hier mal ein Auszug aus der Webbox-Log:

    Und hier die WebAPI-Log:´

    Code
    Connection to david WebAPI Service established
    David WebAPI started
    External health check to 'https://da***1.goip.de:8443/' failed within 21.132,10ms: Unreachable

    Zum Test habe ich sogar mal die Windows-Firewall komplett deaktiviert und in der FritzBox den Exposed Host angemacht, leider weiterhin ohne Erfolg.

    Kann mir da jemand helfen, wo das Problem liegt??

    Oder wie ich den Server richtig installiere, dass er via DynDNS erreichbar ist?

    Registriert ist die DynDNS-Adresse in der FritzBox.

  • Das klappt.

    Also mit 127.0.0.1.

    Hab erst jetzt die Log gelesen, wenn du mit einem iPhone zugreifst muss die Adresse zum Zertifikat passen,

    sonst will iOS sich nicht verbinden. Siehst du den im Monitor den Zugriff des iPhones?


    Der Zugriff von Extern auf den HTTP Port klappt? (nur zum Testen...)

  • Weder auf dem 80/443 Port?

    Wenn zwischen Router und Server sonst nix hängt, und auf dem Server keine AV Software läuft...

    Um mehr zu sagen sollte man sich die gesamte Konfig mal anschauen. Gerne per Remote.


    Zugriff auch mal über einen Browser Extern getestet (Safari iOS)?

  • Ich konnte das Problem jetzt eingrenzen und es scheint wirklich am SSL zu liegen.

    Zu meinem Unverständnis ist der Port 80 einfach nicht für die Webbox erreichbar. In der FritzBox ist alles freigegeben, selbst die Windows-Firewall ist komplett abgeschaltet. Dennoch sagt das Prüf-Tool ( unter der SSL-Bestellung im DAVID-Admin ), dass Port 80, 443 usw. nicht erreichbar seien - es ist aber alles freigegeben!


    Stelle ich am iPhone alles per WLAN und der festen Server-IP ein, klappt alles wunderbar.

    Auch die Webbox-Log spricht mit mir.

    Stelle ich es aber auf mobile Daten am iPhone um und setze jetzt den DynDNS wieder ein, ist funkstille.


    Also das ist für mich unbegreiflich, wie das sein kann!

    Selbst mit dem kompletten Abschalten der Windows-Firewall und des Defenders klappt es nicht!

    Habe zum Test sogar Win 10 Pro installiert und auch dort alles abgeschaltet - gleiches Ergebnis.


    Dass es am iPhone nun nicht mehr geht, habe ich ebenfalls schon herausgefunden. Apple hat die selbstsignierung von SSL-Zertifikaten raus genommen. Somit klappt das, was ich bisher an Lösung gefunden habe leider nicht. Ich habe genau die gleiche Meldung auf dem iPhone, wie rechts der Screenshot.

    Account löschen und neu hinfuzügen bringt leider auch keine Lösung - jedenfalls nicht, wenn ich es mit den externen Daten versuche ( DynDNS ), intern im WLAN ist alles super mit fester IP.

    Ich brauche also ein öffentliches Zertifikat, was ich aber nicht bestellen kann über den DAVID-Admin, da ja der Port 80 und 443 verriegelt und verammelt zu seien scheint.

    Der 'Trick' mit dem SSL-Slider deaktivieren, dann Einstellungen übernehmen und dann SSL wieder aktivieren klappt leider nicht.

  • Also, ich möchte es kurz auflösen.

    Der Fehler ist mir echt ultra peinlich!

    Nutze den DAVID-Server zu Hause privat, weil ich einfach begeistert bin von dem Programm.

    Dort hatte ich in der FRITZ!Box den Port 443 und 80 für das Spiel UNO freigegeben, weil es sonst nicht vernünftig im Multiplayer lief und immer wieder abstürzte.

    Allerdings war die Freigabe auf meinem Desktop-PC ( mit anderer IP usw. ). Daher habe ich mir da nichts weiter gedacht.

    Nachdem ich die Freigaben gelöscht habe, klappte auf einmal alles im DAVID.

    Port 80 läuft, 443 läuft und alles ist in Ordnung. Selbst die Let's Encrypt-Bestellung lief jetzt einwandfrei durch und somit hat auch das iPhone wieder meine eMails und den Kalender synchronisiert.

    Zwar musste ich den Account löschen und neu hinzufügen, aber das war das kleinste Problem.


    Trotzdem herzlichen Dank!

    Was ich allerdings nicht wusste, dass die FRITZ!Box nur einmal jeden Port freigeben kann. Ich dachte, ich kann für jeden Rechner jeden Port freigeben. Also zB. Desktop-PC Port 443, DAVID-Server 443 und beide können diesen nutzen. Dem ist halt nicht so, deshalb hat die FRITZ!Box auch wohl bei der noch vorhandenen UNO-Freigabe aus meinem DAVID-Server Port 443 einen 61010 oder so gemacht....

  • Ja, also so ganz rund läuft es doch noch nicht...

    Komisch ist, wenn ich den Client jetzt z.B. ne Stunde offen lasse, ohne ihn zu benutzen, friert er ein. Ich kann also nicht mehr scrollen und wenn ich was anklicke, wird das Bild komplett schwarz und ist nach ca. 15 Sekunden wieder da und ich kann den Client 'ganz normal' benutzen.


    Eingeloggt bin ich über die DynDNS-Adresse des Servers.

    Wenn ich den Server-Namen aus der Liste im Login-Screen auswähle, komme ich mit meinen und auch mit anderen Login-Daten nicht in den Client!

    Oder empfiehlt es sich, sich Netzwerk-Intern über die interne Server-IP einzuloggen? Weil das geht.

    Ich meine aber, dass ich mich vor der Neuinstallation über den Server-Namen aus der Liste des Client's eingeloggt habe.

    Und wenn ich mich jetzt z.B. wo anders ( also extern ) am Client anmelde, müsste ich ja auch die DynDNS-Adresse nutzen. Dann wäre das Problem ja wieder da....

    Die Option 'Client Menü -> Optionen -> Einstellungen -> Ansicht -> Eintragsliste -> die Checkbox »Anzeige des Betreffs erweitern«' habe ich schon deaktiviert, jedoch ist das Problem weiterhin da.

  • Port forwarding ist immer 1zu1. Woher soll die Fritzbox denn wissen welches Paket über Port 443 an den einen oder anderen Client soll?

  • Neues Problem:


    Beim Versenden von eMails vom iPhone aus werden diese nur im Ausgang gespeichert, wenn ich eine blanke eMail schreibe vom Handy.

    Antworte ich auf eine empfangene eMail, wird diese nicht im Ausgang gespeichert und auch nicht verschickt!


    Woran liegt das nun wieder??

    Ich kann ja am iPhone nichts einstellen.


    /edit

    Problem gelöst:

    Ich hatte bei den Signaturen für die Absender-eMailadressen nur '@@von <Adresse>' stehen. Richtig ist es so: '@@von <Adresse>@@' - jetzt klappt es auch. :)

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!