Keine Eingehenden Verbindungen mehr seit Rollout 331 und Windows Update

  • Hallo und schönen guten Tag,


    Ich habe so ziemlich seit dem letzten Windows Update das Problem das keine eingehenden Verbindungen mehr möglich sind.

    Da bei solch Problemen die Firewall wohl eine große Rolle spielt habe ich diese schon komplett deaktiviert.

    Das Versenden ist Problemlos möglich nur kommt nichts mehr rein.

    Am Router wurde nichts in der Zeit geändert bzw. geupdatet.

    Bin mir ziemlich sicher das es mit dem letzten Windows Update zu tun hat jedoch finde ich den Fehler nicht und hoffe das mir

    hier einer helfen kann.


    Gruß

    D.S.

  • Thomas

    Approved the thread.
  • Hallo,


    mit so wenig Information wird dir niemand helfen können oder wollen...


    - David installiert auf was?

    - keine eingehenden Verbindungen? Smartphone oder Mails? SMTP oder POP3? EAS oder IMAP/POP3? SmartClient?
    - Router ist was für ein Gerät?

    - DYNDNS- oder feste IP?
    - Portforwarding?


    Fragen über Fragen...


    CU Barabas

  • Hallo,

    also David ist auf einen Windows 10 Rechner installiert und dient darauf nur als reines Email Programm zum Senden und Empfangen.

    Dem ganzen ist eine Fritz Box 7590 als Router installiert.

    Die Windows eigene Firewall ist deaktiviert und es ist auch keine andere installiert.


    Keine eingehenden Verbindungen heisst das keine Emails mehr vom Telekom Server abgeholt werden.

    Der Verbindungstest sagt im oberen Fenster das alle ausgehenden Verbindungen in Ordnung sind jedoch die eingehenden Verbindungen der einzelnen Module komplett fehlschlagen.

    Netstat sag mir das die erforderlichen Ports eigentlich abgehört werden.

    So könnte man meinen das die Fritz Box die eingehenden Verbindungen blockt jedoch warum sollte sie das ohne Veränderungen tun ?

    Das ganze hat in der Kombination jetzt 3 Jahre seinen Dienst verrichtet und urplötzlich nicht mehr.


    Gruß

    D.S.

  • Um Mails vom Telekom-Server abzuholen (per POP3/Grabbing Server vermute ich mal), brauchst du keine eingehenden Verbindungen. Vom WAN ins LAN geöffnete Ports sind nur dann erforderlich, wenn du auf lokal angebotene Dienste vom Internet aus zugreifen möchtest. Also: Web Access, Smart Client, ActiveSync (Smartphone-Anbindung), Zertifikats-Anforderung via Let's Encrypt... Wenn ihr diese Funktionen nicht nutzt, sondern David lediglich Mails holen und versenden soll, ist die Einstellung aktuell vollkommen OK (die Windows-Firewall darf gerne wieder eingeschaltet werrden). David verhält sich in diesem Fall wie ein einfaches Mailprogramm auf einem PC. Um Thunderbird unter Windows zu nutzen, musst du ja auch keine eingehenden Ports öffnen. In der Fritzbox ist (wie bei den meisten anderen Heim-Routern) standardmäßig von innen nach außen alles auf, und von außen nach innen alles zu.


    Dein Problem hängt sehr wahrscheinlich nicht mit der Firewall und auch nicht mit dem Router zusammen. Aufschluss wird dir eher das Protokoll z. B. aus dem Grabbing Server geben (DvAdmin -> E-Mail -> Grabbing Server -> Rechtsklick + "Status Monitor"). Wenn ich es recht weiß, kann man sich bei T-Online/Telekom seit einiger Zeit nicht mehr mit dem Account-Passwort anmelden, sondern muss für die POP3-Abfrage ein eigenes Kennwort erstellen - ich vermute mal etwas in der Richtung.


    Eventuell hängt auch einfach nur der Grabbing Server fest. Habt ihr Sitecare, aktualisiert sich David automatisch? Wenn ja, ist das Rollout 331 eingespielt (bei 330 gab es Probleme mit einem festhängenden Mailabruf)? Testweise den Rechner mal neu gestartet?


    Ansonsten geh mal wie oben beschrieben in den Monitor des Grabbing Servers, dort in den Reiter "Communication", lösche unten mit "Clear" alle Mitteilungen und warte auf den nächsten Abholzyklus. Was erscheinen dort für Nachrichten?


    EDIT: Ups, hab' gerade gesehen, dass in der Überschrift von Rollout 331 die Rede ist. Daher SOLLTE der David-interne Bug kein Thema mehr sein. Neustart der Dienste oder des PCs ist dennoch einen Versuch wert.

  • Hallo,

    vielen Dank schon mal für die Antwort.

    Neustart der Dienste und des Rechners erfolgte schon mehrmals.

    Ich habe mal Deinen Rat befolgt und den Monitor des Grabbing Servers angesehen.

    Soweit fast alles ok bis auf den Eintrag der rot erscheint :....


    (1) CheckMsgIDandSize: SQLITE_CORRUPT [11]: Das Image der Datenbankfestplatte ist fehlerhaft
    (1) GetMsg = -1, beim Lesen der Nachrichtenliste ist ein Fehler aufgetreten!
    (1) BEENDEN
    (1) + OK Abmelden.


    Was mit dem Image passiert sein soll ist mir schleierhaft.

    Das einzige was mir noch einfällt ist das die Maschine wegen des Drucker Bugs in Windows mal mit einen Bluescreen abgeschmiert ist.Das war auch so ziemlich ein Ereignis welches zeitgleich aufgetreten ist.


    Gruß

    D.S.

  • Das klingt für mich so, als sei die Datenbank mit den bereits abgeholten Nachrichten defekt. Habt ihr in den Eigenschaften des Postfachs die Option aktiviert, dass Mails für eine bestimmte Zeit beim Provider liegen gelassen werden (POP3-Postfach -> Optionen -> "Kopie aller Nachrichten auf dem Server belassen)?


    Stoppe mal den Dienst "Grabbing Server" und suche nach einer .mldb-Datei im Verzeichnis \david\apps\dvgrab\code. Wenn du diese Datei verschiebst, wird David nach einem Neustart des Grabbing Servers vermutlich wieder alle Mails abholen - ACHTUNG: Durch die "Liegenlassen"-Funktion trudeln dann auch ältere Nachrichten wieder ein - vgl diesen Thread. Es ist daher ggf. gut, vorher per Web-Login das Postfach aufzuräumen oder im David temporär eine Regel einzurichten, die die Mails in einen speziellen Ordner laufen lässt, um sie dann händisch zu sortieren.

  • Hallo,

    das war der goldrichtige Tip,nach dem Verschieben der Datei wurde alles wie gewohnt wieder abgeholt und die alten Mails sind auch noch da.

    Das Postfach hatte ich vorsorglich schon mal vorher aufgeräumt sonst wären da um die 1000 Mails eingetroffen.

    Es funktioniert wieder alles wie vor dem Ereignis.


    Nur für mich zum Verständnis,aus welchen Grund hatte sich die Datei zerstört ?

    War es der Bluescreen ?


    Ich bedanke mich nochmal in aller Form bei dem der zur Lösung beigetragen hat !!


    Nur zur Info,ich bzw wir sind Endanwender die von ihren Systemhaus in der Vergangenheit quasi Systematisch gemolken wurden.Die hatten einen Zugang über Team Viewer und konnten sich quasi jederzeit auf den Server schalten.

    Seit ich das abgestellt habe und der Zugang dicht ist bedarf es keinen Wöchentlichen Anruf mehr um was richten zu müssen.

    Nur bei diesen speziellen Thema mit David kam ich dann leider nicht mehr weiter.

    Aber Prima das es solche Foren gibt.


    Gruß

    D.S.

  • Durchaus möglich, dass der Bluescreen schuld war - Datenbanken sind bei David leider wenig fehlertolerant, daher können sich die üblichen Verdächtigen (wie auch z. B. die activesync.db, archive.dat usw.) bei harten Resets gerne mal "zerlegen".


    Generell war David nie als reines Endkunden-Produkt gedacht; es ist daher stets eine gute Idee, ein bewandertes Systemhaus zumindest in Griffweite zu haben. Wenn ihr mit eurer bisherigen Betreuung nicht zufrieden wart, schau dich mal hier im Forum um, da gibt es einige, den solche Jobs gerne übernehmen. Mich eingeschlossen. ;)

  • Ein David Server sollte halt auch nie auf einem Rechner laufen der normale Nutzerinteraktionen hat und entsprechend absturzgefährdet ist. Selbst wenn man ihn aus Kostengründen in einer sehr kleinen Installation auf einem Rechner mit Windows 10 statt mit einem Windows Server Betriebssystem laufen lässt sollte er dort in Ruhe gelassen werden und darüber hinaus stets an einer USV hängen.
    Denn je nach dem welche Datenbankdatei(en) da gerade bei einem Absturz zerschossen werden - weil gerade in dem Moment noch unfertige Schreibzugriffe stattfanden - kann der Aufwand des dann fälligen Aufräumens bzw. der Reparatur ganz schnell mal über die Kosten eines zusätzlichen Rechners und der dazu gehörenden Windows Server Lizenz übersteigen.

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!