E-Mail und Kalender am Smartphone

  • Moin,


    ich würde gerne E-Mails und Kalender auf einem Smartphone mit Android 10 und einem iPhone realisieren.


    Ich habe mir hier schon einen Wolf bzw. immerhin ein Wölfchen gesucht und finde keine komplette Anleitung, die tatsächlich alles beschreibt

    1) Einstellungen am Server

    - Zertifikat einrichten und einbinden

    - Domain verbinden

    - Allgemeine Einstellungen

    2) Einstellungen am Router

    - Portfreigabe

    3) Einstellungen am Smartphone


    Vielen Dank für jeden Hinweis..

  • Hallo,


    schön wäre es, wenn der nach Hilfe Suchende ein paar Infos zur Verfügung stellen würde:

    - David Version?

    - Sitecare?
    - Webbox schon in Betrieb?
    - Smartclient?

    - Internetzugang (feste IP, Dyndns, Router)?

    - Firewall?

    - SSL-Zertifikat?


    Mit all diesen wichtigen Informationen könnte man eventuell wertvolle Tipps geben, ansonsten bleibt meine Glaskugel ziemlich trüb :)


    VG

    Barabas

  • Moin, ja sorry.. vollkommen richtig


    Ich wollte ja eine grundsätzliche Anleitung, damit ich mich so durchwuseln und alles mal ausprobieren/testen kann.


    Der erste Mitarbeiter seitens Tobit hat nicht erwähnt, dass der SmartClient Kalender nicht kann.

    Dann wird es vermutlich Active Sync. Trotzdem wollte ich mal alles durchgehen und mir das anschauen, eben auch den Smart Client.


    Nach der Tobit Anleitung, habe ich mich der WebAPI gewidmet und bin dort auf den Domain Name gestoßen. Ich habe dort einen freien Domainnamen eingetragen und den AAAA Eintrag in den DNS Einstellungen beim Provider (IONOS) auf die IP des Routers eingestellt. Zudem den Port 8443 im Router auf den Server geroutet. Nur um zu testen dann eben das selbst signierte Zertifikat eingerichtet und angegeben. Die Prüfung der Erreichbarkeit in den Einstellungen der WevAPI führt zu einer Fehlermeldung:

    1. Der angegebene Name passt nicht zum Zertifikat

    2. Die david WebAPI antwortet nicht korrekt

    Ursachen Dienst nicht gestartet oder Port belegt

    (ist gestartet und der Port nicht belegt)

    3. Es konnte keine Verbindung hergestellt werde


    - David Version? Tobit David3

    - Sitecare? ja

    - Webbox schon in Betrieb? nein

    - Smartclient? ja, geht jedoch nicht

    - Internetzugang (feste IP, Dyndns, Router)? feste IP ja, DynDNS nein, Router ist eingestellt

    - Firewall? eingestellt

    - SSL-Zertifikat? ein selbst signiertes Zertifikat fürs Erste


    Also von mir aus EAS

    Was müsste ich tun?


    Danke übrigens..

  • Wenn's mit ActiveSync laufen soll, brauchst du die WebAPI nicht, nur die Webbox mit Port 443. Sowie Port 80 für den Bezug des Let's-Encrypt-Zertifikats. Ein selbst erstelltes Zertifikat wird von den meisten modernen Smartphones hier nicht mehr akzeptiert, du musst also entweder über LE automatisch beziehen (ist im Sitecare mit drin) oder ein Zertifikat zukaufen und manuell einspielen. Wenn du selbst kaufst, kann der Port 80 geschlossen bleiben.


    Also:

    • Bau dir eine Subdomain wie david.meinedomain.invalid (oder nimm deine unbenutzte Domain)
    • Konfiguriere den AA-Eintrag der (Sub)Domain auf eure feste IP - mit AAAA (IPv6) habe ich das bislang nicht zum Laufen bekommen, sondern nur ganz "klassisch" mit IPv4. Bei der Verwendung von Let's Encrypt ggf. AAAA unkonfiguriert lassen, sonst schaut LE da bevorzugt und ist sauer, wenn der Server über IPv6 nicht erreicht werden kann.
    • Router: Portfreigabe für Port 443 und 80 auf den David-Server, ggf. auch Firewall am Server beachten (wie gesagt, Port 80 kann entfallen, wenn Zertifikat selbst gekauft).
    • Dienst Webbox starten und auf automatischen Start stellen.
    • Webbox -> Konfiguration -> Domain eure (Sub-)Domain david.meinedomain.invalid eintragen

    In dieser Konfiguration solltest du per Webbrowser schon auf https://david.meinedomain.invalid draufkommen und einen Login-Prompt erhalten, wohl mit Zertifikats-Warnung. Wenn ja, sind damit prinzipiell die Voraussetzungen für den Exchange-Zugang erfüllt. Je nach Router musst du das ggf. "von außen" machen, also nicht aus dem zu erreichenden LAN, weil einige Modelle kein Hairpin NAT beherrschen. Mit z. B. einer Fritz!Box klappt das, mit Lancoms auch, mit manchen Telekom-Geräten nicht.


    Im David-Client aktivierst du nun unter Einstellungen -> Zugang den Remotezugriff. Der User muss dazu das entsprechende Recht haben (zu vergeben im David-Admin).


    Auf dem Smartphone hangelst du dich durch den Assi für ein neues Exchange-Konto, gehst aber so schnell wie möglich auf "manuell konfigurieren", da einige Dinge nicht automatisch erkannt werden. Mailadresse ist klar, Kennwort wie im David-Client vergeben. Beim Server mischt sich ggf. euer Provider ein, das überschreibst du mit david.meinedomain.invalid. Der Anmeldename ist wie im David-Client vergeben.

    Anschließend konnte man früher[tm] die Warnung bzgl. eines selbst signierten Zertifikats wegklicken, wie gesagt, das geht bei den meisten aktuellen Systemen nicht mehr. Wenn also mit dem Zertifikat etwas nicht stimmt, hakt's dort. Mit LE ist das im David-Admin simpel: Abschnitt "TLS-Verschlüsselung" anklicken, "Neues Zertifikat anfordern", fertig.


    Bei der Gelegenheit gleich im Admin Rechtsklick auf "TLS-Verschlüsselung" und die Kompatibilität auf "Modern" umstellen. TLS 1.0 und 1.1 braucht heute (fast) niemand mehr.

  • Hab da mal vor einiger Zeit Videos zu erstellt


    External Content youtu.be
    Content embedded from external sources will not be displayed without your consent.
    Through the activation of external content, you agree that personal data may be transferred to third party platforms. We have provided more information on this in our privacy policy.

    External Content youtu.be
    Content embedded from external sources will not be displayed without your consent.
    Through the activation of external content, you agree that personal data may be transferred to third party platforms. We have provided more information on this in our privacy policy.

    https://ihr-it.support
    Bietet seit über fünfzehn Jahren Systemhaus Lösungen für kleine bis mittlere Kunden an.
    Auf meiner Homepage finden Sie Infos zu allen Zertifizierungen und Partnerschaften ;)
    Support Hotline: 07345 23 63 80

  • Moin und vielen Dank!

    Ich war leider krank und konnte mich bis heute nicht mehr kümmern und dazu melden.


    Leider funktioniert(e) es nicht. Folgendes habe ich durchgeführt

    1. Anlegen einer Subdomain (ionos)

    2. A Einträge in der DNS Konfiguration bei IONOS auf die fest ÖIP umgestellt

    3. Fritz Router Portfreigabe für Port 443 auf den David Rechner (Windows Server) eingestellt

    4. Fritz Router Portfreigabe für Port 80 auf den David Rechner (Windows Server) eingestellt

    5. Im David Admin den Dienst Webbox starten und auf automatischen Start gestellt

    6. Im David Admin unter "TLS-Verschlüsselung", "Neues Zertifikat anfordern" versucht ein Zertifikat anzufordern

    Das Zertifikat konnte nicht angefordert werden.

    7. Domain und Adresse eingetragen und Übertragung getestet


    Was bedeutet Falsches Modul?


    Unter TLS Zertifikate sind mehrere Zertifikate eingetragen

    mail, postman, webAPI und webBox

    Nur unter webAPI steht eine lange Gültigkeitsdauer. Ich vermute das entspringt den ersten Versuchen mit der API für den Smartclient und ist das selbst erstellte Zertifikat.


    Kann ich die beiden Einträge für webBox und webAPI problemlos löschen?


    Danke und viele Grüße

    Nachträgl. frohes Neues!

  • Bevor du ein Let's-Encrypt-Zertifikat anfordern kannst, muss deine Webbox auf Port 80 (von extern) korrekt antworten. "Falsches Modul" bedeutet, dass sich da ein anderes Programm vorgedrängelt hat, daher ist die Webbox lokal automatisch auf Port 81 ausgewichen. Ggf. ein anderer Webserver (IIS?) oder ein Systemdienst? Prüf mal mit "netstat -ano", welche PID sich den Port 80 geschnappt hat. Oft ist das "4", dann bezieht sich das auf was Windows-eigenes.


    Am einfachsten ist im Router ein Port Forwarding von extern 80 auf intern 81 und Umstellen der Webbox fest auf Port 81 (in der webbox.ini).

  • Wenn ich mir die ganzen fehlgeschlagenen Tests bei den eingehenden Verbindungen anschaue fehlen da augenscheinlich auch noch entweder einige Portforwardings auf dem Internet Router, oder Einträge in einer der beteiligten Firewalls, also auf dem Router oder dem Server selbst.

    Damit der gewünschte eMail und Kalender Zugriff vom Smartphone via EAS Protokoll auf den Server funktioniert müssen mindestens folgende Verbindungen freigegeben sein:
    Port 80 extern auf Port 80 oder 81 des David Servers
    Port 443 extern auf Port 443 des David Servers

    Falls darüber hinaus auch der Smartclient am Smartphone oder der Smartclient Webzugriff von einem Notebook funktionieren soll braucht es noch:

    Port 8443 extern auf Port 8443 des David Servers

    Wenn man von extern auch mit dem normalen David Client zugreifen können möchte braucht es:
    Port 267 extern auf 267 des David Servers

    Ganz wichtig ist das Du in Deiner Auflistung oben Schritt 6 und 7 in der Reihenfolge vertauscht hast.
    Da Du offenkundig auch entweder die Ports nicht korrekt weitergeleitet oder die weitergeleiteten Ports nicht in den Firewalls freigegeben hattest muss auch das noch vor deinem Schritt 6 passieren, welcher damit eher so Schritt 10 wäre ;)

  • Ja Danke!

    Ich hatte nur den Port 80 geroutet, nach dem ich den Bereich auf Port 81 erweitert habe, klappt der Test auf diesem Port. Jedoch klappt es nicht mit dem Zertifikat: Hier kommt die Meldung "Ungültiger Domainname"


    Gebe ich den Domainname im Browser ein, kommt eine 404 Fehlermeldung des Servers

    "Datei oder Verzeichnis wurde nicht gefunden"

    Gebe ich die öffentliche IP ein, lande ich auf der IIS Webseite des Servers.


    In der Firewall sind alle David Module auf allen Ports freigegeben.

    Ich habe mal die Firewall deaktiviert und das Zertifikat angefordert. Hier kommt dann "Fehler bei der Verarbeitung des Auftrags, Failed to connect WebBox.."

    Auch nach Neustart der WebBox das Gleiche..


    Der David Client über 267 funktioniert problemlos.



    Beste Grüße

  • Ok, Tobit hat mir auch geschrieben.

    Sie würden den IIS sehen und den solle ich deaktivieren, wenn ich ihn nicht benötige.

    Habe ich gemacht und nun kommt nach der Zertifikatsanforderung was Neues:


    Fehler bei Verarbeitung des Auftrags (Failed to validate DNS-records (A, CNAME), Invalid domain provided)


    Ich bin in die DNS Einstellungen des Providers und habe CNAME auch auf die ÖIP umgestellt.

  • Nein, nicht den Freigabebereich erweitern - du musst sicherstellen, dass der externe Port 80 (der MUSS für Let's Encrypt 80 sein) beim David ankommt. Wenn du vorher den IIS gesehen hast, ging extern 80 auf intern 80 und extern 81 auf intern 81, das nützt dir nichts.


    Mach ein Forwarding von extern 80 auf intern 81, dann kannst du auch den IIS wieder einschalten. ;)


    Sobald Port 80 läuft (du musst von extern bei Aufruf eurer Seite mit http:// die Anmeldung von David bekommen, also Abfrage Username/Kennwort), trägst du bei der Zertifikatsanforderung eure korrekte Subdomain ein (david.deinedomain.invalid) - Zertifikate können nur für Hostnamen ausgestellt werden, nicht für IP-Adressen. Und der David muss über david.deinedomain.invalid:80 erreichbar sein. CNAME bitte wieder rauslöschen, den brauchst du bei einer festen IP nicht.


    Nach Zertifikats-Bezug sollte die Webbox sich bei Neustart des Dienstes auch korrekt an Port 443 binden - gut möglich aber, dass da ebenfalls der IIS draufsitzt. Bekommst du eine Antwort, wenn du lokal https://127.0.0.1 aufrufst? Dann muss der Port noch "freigeräumt" werden. Sobald das Ganze durch ist, würde ich in der Webbox übrigens die Option "Port 80 nur für Let's Encrypt benutzen" anhaken, denn unverschlüsselte Verbindungen will man heute eh nicht mehr haben...


    Viel Erfolg!

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!