Activsync funktioniert plötzlich bei einem Android User nicht mehr

  • Hallo zusammen,

    ich verwende seit Jahren David3 und mehrere User nutzten die Exchange-Anbindung um Kalender zu synchronisieren.

    Bei mir wurde plötzlich mobil nichts mehr aktualisiert, aber bei einem weiteren User funktioniert es immer noch problemlos.

    Ich habe schon versucht, die Activsync.db umzubennenen und das Konto auf dem Smartphone neu einzurichten. Ich bekommedie Meldung:

    "Bestätigen des Kontos nicht möglich

    Ein Sicherheitsverbindungsfehler ist aufgetreten."

    Ich hann aber mit dem Web-Client problemlos zugreifen, so dass wohl der Remotezugang passend sein muss. Es ist auch egal, ob ich im internen Netzt bin und mit der passenden IP direkt auf den Server zugreife oder von außen über DYNDNS

    Da die Verschlüsselung ja wohl in allen Fällen genutzt wird und das Ganze bei dem anderen User auch läuft, sollte das Zertifikat doch auch OK sein.

    Wo liegt mein Denkfehler?

    Gruß Rudolf

  • ... ja, wie oben schon geschrieben:


    Ich kann aber mit dem Web-Client problemlos zugreifen, so dass wohl der Remotezugang passend sein muss. Es ist auch egal, ob ich im internen Netz bin und mit der passenden IP direkt auf den Server zugreife oder von außen über DYNDNS

    Da die Verschlüsselung ja wohl in allen Fällen genutzt wird und das Ganze bei dem anderen User auch läuft, sollte das Zertifikat doch auch OK sein.

  • Was sind das für Smartphones?
    Sind es beides die gleichen?
    Wenn nicht, was für ein Smartphone nutzt der Nutzer bei dem alles funktioniert und was für ein Smartphone nutzt der bei dem es nicht funktioniert?
    Welche eMail App wird auf dem jeweiligen Smartphone genutzt?

  • Das eine ist ein Samsung A40 und das andere ein S20FE.
    Wir gleichen nur die Standard-Kalender APP ab

    Leider kann man wohl ein einmal angelegtes Konto nicht mehr bearbeiten So kann ich auch nicht mehr schauen, was ich auf dem A40 eingerictet hatte.

    Das Anlegen des Konto´s auf dem S20FE funktioniert aber leider nicht wegen der Fehlermeldung:
    "Bestätigen des Kontos nicht möglich

    Ein Sicherheitsverbindungsfehler ist aufgetreten."

    Da ich vermute, dass das SSL-Zertifikat auch genutzt wird, um das A40 abzugleichen, sollte das hoffentlich OK sein.
    Leider weiß ich auch nicht, wie ich ein alternatives möglichst kostenfrei bekomme.

    Anbei auch das Ergebnis des Testes der Verbindungen. Vielleicht kann man daraus etwas sehen?

  • Ports passen soweit, eingehend muss für ActiveSync nur 443 ankommen. Ich tippe auch zu 90% auf ein Zertifikats-Problem. Vielleicht ist ein Gerät da toleranter als das andere - früher[tm] war es gängig, dass auch selbstsignierte Zertifikate geschluckt wurden, seit einigen Jahren allerdings wollen die meisten Systeme ein offizielles.


    Was bekommst du denn im Browser angezeigt, wenn die den Webaccess öffnest und mal in der URL-Zeile auf das Schloss klickst?


    Zertifikat kostenlos wird schwierig, ginge wohl über Let's Encrypt, habe ich aber auf manuellem Wege nicht mehr ausprobiert, seit die Funktion in David eingebaut ist (für Installationen mit aktivem Sitecare).


    Bei Kunden ohne Sitecare nehme ich i. d. R. ein günstiges Zertifikat z. B. von GlobeSSL. Das liegt bei knapp 10 Euro brutto für ein Jahr und ist damit auch für kleine Installationen verschmerzbar.

  • für Let's encrypt gibt es hier im Forum - noch aus Zeiten bevor das über Sitecare offiziell unterstützt wurde - recht ausführliche Posts mit Anleitung.
    Das funktioniert auch heutzutage noch einwandfrei wenn man kein sitecare haben möchte und lässt sich ein mal eingerichtet vollständig automatisieren.

  • Hallo,


    die Frage ob es sich um ein gültiges echtes Zertifikat handelt ist aber glaube ich immer noch

    nicht beantwortet, ich denke hier wird der Fehler zu suchen sein.


    Da ich vermute, dass das SSL-Zertifikat auch genutzt wird, um das A40 abzugleichen, sollte das hoffentlich OK sein.

    Hoffen und vermuten hilft nicht wirklich weiter. Im Browser david aufrufen und schauen was das Zertifikat sagt.

  • OK, im Screenshot steht neben der URL ein Ausrufezeichen, und es handelt sich um einen dyndns.org-Host (klappt LE damit überhaupt? Ich meine mich zu erinnern, dass wir bei allen Kunden auf andere Anbieter umgeschwenkt sind oder ein Konstrukt mit CNAME-Weiterleitung gebaut haben, weil die Ausstellung direkt auf xyz.dyndsn.org nicht funktionierte).


    Ich gehe weiterhin davon aus, dass das Zertifikat Schuld ist.

  • Man könnte bei "Strato" für kleines Geld eine Domain bestellen, den kostenlosen https://ipv64.net/ Dyn DNS Dienst und bei Strato in der Domänenverwaltung CNAME auf die IPV64.net Domäne.

    Alternativ bei Strato ein höherwertiges Produkt, welches auch DynDNS beinhaltet.

    Ich hatte das auch schon, das ein Android nach einem "Update" nicht mehr auf einen David Server zugreift, nicht er sich am Zertifikat störte. Dann habe ich ein günstiges Zertifikat erworbei bei SSL.de für 20 Euro im Jahr, dann ging es wieder. Er störte sich denn nur noch am Aussteller des Zertifikats (unknown Issuer), aber es lief trotzdem wieder. Die Barrieren werden immer höher. Als nächstes kommen dann vielleicht verpflichtende Client Zertifikate - von wegen digitale Selbstbestimmung). Apple voran.

  • Man könnte auch versuchen, im Stock-Browser des Mobilgerätes die URL zu öffnen und das Zertifikat zur Liste der vertrauenswürdigen Zertifikate hinzuzufügen.

    Zumindes früher hat das geklappt.


    Ansonsten eine Domain (bei Strato, Htzner, o.ä.) beantragen und im DNS-Bereich eine Subdomain anlegen und deren CNAME auf die DynDNS-Adresse leiten.

    Anschließend über David das LetsEncrypt-Zertifikat erstellen, oder ein eigenes Zertifikat ( z.B. bei psw.net) für die Subdomain beantragen und manuell auf dem David-Server installieren.


    Wenn im Browser die Subdomain ohne Zertifikatsfehler geöffnet wird, dann sollte es auch mit ActiveSync klappen.

  • Um ehrlich zu sein, kenne ich mich mit dem Thema Zertrifikate überhaupt nicht aus.
    Ich hatte mir eines bei der dgn für die eMaul-Zertifizierung besorgt und das funktioniert wohl auch.
    Da ich eben im Administrator für die Webbox ein abgelaufenes Zertifikat gefunden hatte, habe ich das dgn-Zertifikat hier importiert und danach wurde die Anwendung neu gestartet.
    Bei der Einrichtung des Konto kam dann erst dier Meldung, dass das Zetifikat unsicher sei.
    Nach "Weiter" kam dann wieder der übliche Fehler.

    Die DynDNS-Adresse nutze ich auch für RemoteDesktop und wenn ich das Samrtphone im WLAN habe und die IP des Servers eingebe kommt der gleiche Fehler.

    Beim anderen Anwender. bei dem ich das Konto nicht angefasst habe, funktioniert es auch weiterhin 😅

  • Um ehrlich zu sein, verstehe ich nicht, was LetsEncrypt unter erste Schritte erklärt.
    Ich will ja eigentlich kein Zertifikat für eine Webseite 😅
    Ich habe mich da nun registriert, aber wie ich an das Zertifikat komme, ist mir schleierhaft.
    Das Importieren in Tobit scheint ja nicht so schwer zu sein.

  • Da ich eben im Administrator für die Webbox ein abgelaufenes Zertifikat gefunden hatte, habe ich das dgn-Zertifikat hier importiert und danach wurde die Anwendung neu gestartet.

    Da es sich um ein eMail Signatur Zertifikat handel, kann das nicht klappen.


    hier gibt es ein Video zu dem Thema:

    External Content www.youtube.com
    Content embedded from external sources will not be displayed without your consent.
    Through the activation of external content, you agree that personal data may be transferred to third party platforms. We have provided more information on this in our privacy policy.

    https://ihr-it.support
    Bietet seit zwanzig Jahren Systemhaus Lösungen für kleine bis mittlere Kunden an.
    Auf meiner Homepage finden Sie Infos zu allen Zertifizierungen und Partnerschaften ;)
    Support Hotline: 07345 23 63 80

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!